Bug 10028 - ModReceiveOrder works unexpectedly
Summary: ModReceiveOrder works unexpectedly
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-11 13:28 UTC by Jonathan Druart
Modified: 2014-12-07 20:03 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10028: ModReceiveOrder unexpectedly works. (1.21 KB, patch)
2013-04-11 13:29 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10028: ModReceiveOrder unexpectedly works. (1.26 KB, patch)
2013-08-09 01:15 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 10028: ModReceiveOrder unexpectedly works. (1.32 KB, patch)
2013-08-16 12:56 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2013-04-11 13:28:40 UTC

    
Comment 1 Jonathan Druart 2013-04-11 13:29:39 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2013-08-09 01:15:19 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2013-08-16 12:56:01 UTC
Created attachment 20405 [details] [review]
Bug 10028: ModReceiveOrder unexpectedly works.

In C4::Acquisition::ModReceiveOrder, a call to NewOrder is badly used.

NewOrder returns ($basketno, $ordernumber) but in ModReceiveOrder the
ordernumber is got with
  my $ordernumber = NewOrder( $args );

It works because:
sub t{
    return ("a", "b");
}
my $a = t();
say $a;

Will display 'b'.

But it is not really clear.

Test plan:
Check that there is no regression for partial receives.

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 4 Galen Charlton 2013-08-16 16:59:55 UTC
Pushed to master.  Thanks, Jonathan!
Comment 5 Tomás Cohen Arazi 2013-09-13 14:33:36 UTC
This patch has been pushed to 3.12.x, will be in 3.12.5.

Thanks Jonathan!
Comment 6 Bernardo Gonzalez Kriegel 2013-09-14 22:40:40 UTC
Pushed to 3.10.x, will be in 3.10.11