Bug 10072 - "my suggestions" always says "There are no pending purchase suggestions."
Summary: "my suggestions" always says "There are no pending purchase suggestions."
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Kyle M Hall
QA Contact: Jonathan Druart
URL:
Keywords:
: 10223 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-17 18:07 UTC by Kyle M Hall
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10072 - "my suggestions" always says "There are no pending purchase suggestions." (1.10 KB, patch)
2013-04-17 18:09 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 10072 - "my suggestions" always says "There are no pending purchase suggestions." (1.09 KB, patch)
2013-04-17 22:33 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 10072 - "my suggestions" always says "There are no pending purchase suggestions." (1.19 KB, patch)
2013-04-19 13:49 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2013-04-17 18:07:45 UTC

    
Comment 1 Kyle M Hall 2013-04-17 18:09:28 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2013-04-17 22:33:01 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2013-04-19 13:49:38 UTC
QA comment:

To test this patch IndependantBranches must be off (added to the test plan).
Works as expected, the fix is consistent.

Marked as Passed QA.
Comment 4 Jonathan Druart 2013-04-19 13:49:49 UTC
Created attachment 17551 [details] [review]
Bug 10072 - "my suggestions" always says "There are no pending purchase suggestions."

Test Plan:
1) Switch off the IndependantBranches syspref
2) Log into the OPAC
3) Place a suggestions
4) Instead of seeing your suggestion, you will see "There are no pending
   purchase suggestions."
5) Apply this patch
6) Reload the page
7) You should now see your suggestions

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 5 Jared Camins-Esakov 2013-04-20 03:17:28 UTC
This patch has been pushed to master and 3.12.x.
Comment 6 Chris Cormack 2013-04-27 05:32:17 UTC
Pushed to 3.10.x will be in 3.10.6
Comment 7 Jesse Weaver 2013-05-15 21:00:18 UTC
*** Bug 10223 has been marked as a duplicate of this bug. ***