Bug 10107 - opacbookbag shouldn't prevent from adding items to a list in the OPAC
Summary: opacbookbag shouldn't prevent from adding items to a list in the OPAC
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Tomás Cohen Arazi
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-24 14:16 UTC by Tomás Cohen Arazi
Modified: 2013-12-05 20:05 UTC (History)
3 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10107 - opacbookbag shouldn't prevent from adding items to a list in the OPAC (1.56 KB, patch)
2013-04-24 14:44 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10107 - opacbookbag shouldn't prevent from adding items to a list in the OPAC (1.67 KB, patch)
2013-04-24 17:38 UTC, Owen Leonard
Details | Diff | Splinter Review
PASSED-QA-Bug-10107-opacbookbag-shouldn-t-prevent... (2.00 KB, patch)
2013-04-25 06:21 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 10107 - opacbookbag shouldn't prevent from adding items to a list in the OPAC (1.98 KB, patch)
2013-04-25 11:09 UTC, MJ Ray (software.coop)
Details | Diff | Splinter Review
Bug 10107 - opacbookbag shouldn't prevent from adding items to a list in the OPAC (1.98 KB, patch)
2013-04-26 18:25 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2013-04-24 14:16:42 UTC
To reproduce:
- Disable the opacbookbag syspref
- Login in the OPAC
- Create a list (I tested a private one)
- Search in your db for some biblios.
- Choose some and add them to the created list
- Go to your users's page, to the my lists tab
- Your list is empty.
Comment 1 Tomás Cohen Arazi 2013-04-24 14:28:33 UTC
I confirm this in both 'prog' and 'ccsr'
Comment 2 Tomás Cohen Arazi 2013-04-24 14:32:33 UTC
(In reply to comment #1)
> I confirm this in both 'prog' and 'ccsr'

Also only a bug on the search results page, in the detail page it works as expected.
Comment 3 Tomás Cohen Arazi 2013-04-24 14:44:08 UTC Comment hidden (obsolete)
Comment 4 Marcel de Rooy 2013-04-24 14:44:32 UTC
Tomas:
Via this report I connect to the encoding stuff: Search for something with diacritics. Try to add it to a list with bookbag disabled. You will see a mangled search expression without results and no item added.
Comment 5 Owen Leonard 2013-04-24 17:38:52 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2013-04-25 06:21:09 UTC
Created attachment 17665 [details] [review]
PASSED-QA-Bug-10107-opacbookbag-shouldn-t-prevent...
Comment 7 Marcel de Rooy 2013-04-25 09:46:30 UTC
(In reply to comment #4)
> Tomas:
> Via this report I connect to the encoding stuff: Search for something with
> diacritics. Try to add it to a list with bookbag disabled. You will see a
> mangled search expression without results and no item added.

Bug 10114 is created for this new bug.
Comment 8 MJ Ray (software.coop) 2013-04-25 11:09:51 UTC Comment hidden (obsolete)
Comment 9 Jared Camins-Esakov 2013-04-26 01:14:21 UTC
I cannot reproduce this problem. Is there anything else I might need to know? However, when I disable the opacbookbag syspref all the other javascript on the page breaks.
Comment 10 Katrin Fischer 2013-04-26 04:47:36 UTC
I did my test in CCSR and it worked like described. There was still a [News list] link in the dropdown on top of the result list, but if you clicked on it, nothing happened. After applying the patch and reloading the patch the normal popup came up and it worked nicely.
Comment 11 Jared Camins-Esakov 2013-04-26 11:56:30 UTC
This patch has been pushed to master and 3.12.x.

I was unable to replicate the problem, but this patch did not make things worse for me and fixed things for others so I have pushed anyway.
Comment 12 Katrin Fischer 2013-04-26 18:25:07 UTC Comment hidden (obsolete)
Comment 13 Chris Cormack 2013-04-27 21:35:14 UTC
Pushed to 3.10.x and 3.8.x will be in 3.10.6 and 3.8.13