Bug 10148 - 007 not filling in with existing values
Summary: 007 not filling in with existing values
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Mark Tompsett
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-29 14:40 UTC by Nicole C. Engard
Modified: 2017-12-07 22:17 UTC (History)
10 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10148: Marc21 field 007 builder improper reload values (5.00 KB, patch)
2016-07-05 20:45 UTC, Mark Tompsett
Details | Diff | Splinter Review
Bug 10148: Marc21 field 007 builder improper reload values (5.06 KB, patch)
2016-08-06 18:34 UTC, Nick Clemens
Details | Diff | Splinter Review
[PASSED QA] Bug 10148: Marc21 field 007 builder improper reload values (5.12 KB, patch)
2016-08-07 09:15 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2013-04-29 14:40:13 UTC
When you use the 007 builder to view the existing values in the 007 tag, Koha is not pulling these existing values into the builder window. Instead, Koha appears to be using defaults.


For example:

1. Open a record in the editor

2. The existing fixed field values in the 007 tag are: vd ||  ||

3. Using the tag editor, open the 007 tag builder window and you will see that Koha is not dsiplaying the existing values.

4.If you click the OK button Koha enters the following values: vc aa  ak


The problem also exists in the 006 tag as well.
Comment 1 Katrin Fischer 2015-01-06 20:06:51 UTC
Still valid.
Comment 2 Zeno Tajoli 2015-07-16 11:22:42 UTC
The bigger problem is on 007 for Electronic resource and Microform.
The plugin can't handle existing values when positions 06,07,08 must to be worked together.
Comment 3 Mark Tompsett 2016-07-05 20:20:01 UTC
The issue is in the template file. Anything that is 9595 lines long has got to have something wrong with it.
Comment 4 Mark Tompsett 2016-07-05 20:45:13 UTC Comment hidden (obsolete)
Comment 5 Mark Tompsett 2016-07-05 20:49:57 UTC
I can't duplicate the problem for 006.
Comment 6 Nick Clemens 2016-08-06 18:34:45 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2016-08-07 09:12:25 UTC
This is a bad bug in my eyes as it's easy to lose data this way. Patch fixes 007, we still need a fix for 006. 
I am splitting 006 out into a separate bug 17072 so this one can move on.
Comment 8 Katrin Fischer 2016-08-07 09:15:35 UTC
Created attachment 54103 [details] [review]
[PASSED QA] Bug 10148: Marc21 field 007 builder improper reload values

The more correct solution is fix that template file.
However, in the mean time, this works.

TEST PLAN
---------
 1) find a record
 2) edit record
 3) click value builder for 007
 4) change everything to pipes as much as possible.
    (use Motion Picture to get all 00-22 values)
 5) save
    -- should save just fine.
 6) click the value builder again
    -- OOPS! Bad reload.
 7) prove t/db_dependent/FrameworkPlugin.t
    -- NOISY 007 messages.
 8) apply patch
 9) click the value builder again
    -- good reload
10) prove t/db_dependent/FrameworkPlugin.t
    -- No noise related to 007.
11) run koha qa test tools.

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Kyle M Hall 2016-08-10 13:22:52 UTC
Pushed to master for 16.11, thanks Mark!
Comment 10 Frédéric Demians 2016-08-23 09:35:18 UTC
Pushed in 16.05. Will be in 16.05.03.
Comment 11 Julian Maurice 2016-08-23 15:28:42 UTC
Pushed to 3.22.x, will be in 3.22.10