Bug 10155 - Patron search should remember search options selected
Summary: Patron search should remember search options selected
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Keywords:
: 5129 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-29 21:08 UTC by Katrin Fischer
Modified: 2015-06-04 23:33 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10155: Patron search should remember search type options selected (1.59 KB, patch)
2014-07-15 08:31 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED OFF] Bug 10155: Patron search should remember search type options selected (1.68 KB, patch)
2014-07-20 21:21 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 10155: Patron search should remember search type options selected (1.73 KB, patch)
2014-07-25 14:14 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-04-29 21:08:37 UTC
In patron search Student and library options keep the selected values after sending the search, but Search fields, Search type and Order by revert to default.
Comment 1 Owen Leonard 2013-04-29 22:21:57 UTC
*** Bug 5129 has been marked as a duplicate of this bug. ***
Comment 2 Katrin Fischer 2014-07-12 14:24:46 UTC
Search type at the top still reverts to the default.
Comment 3 Jonathan Druart 2014-07-15 08:31:00 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2014-07-20 21:21:53 UTC Comment hidden (obsolete)
Comment 5 Kyle M Hall 2014-07-25 14:14:50 UTC
Created attachment 30113 [details] [review]
[PASSED QA] Bug 10155: Patron search should remember search type options selected

The search type reset to the default.

Test plan:
1/ go on the patrons home page
2/ Launch a search in the header and select the second value for "search
type" ("contains").
3/ Verify the search type is set to "contains" on the results page.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Works as described.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 6 Tomás Cohen Arazi 2014-07-30 17:25:50 UTC
Patch pushed to master.

Thanks Jonathan!