Bug 10196 - items table partially hidden in marc view in ccsr
Summary: items table partially hidden in marc view in ccsr
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-05 13:45 UTC by Nicole C. Engard
Modified: 2013-12-05 20:09 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
item table cut off in marc view (19.79 KB, image/png)
2013-05-05 13:45 UTC, Nicole C. Engard
Details
Bug 10196 - items table partially hidden in marc view in ccsr (1.19 KB, patch)
2013-05-10 20:07 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10196 - items table partially hidden in marc view in ccsr (1.26 KB, patch)
2013-05-11 01:42 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[PASSED QA] Bug 10196 - items table partially hidden in marc view in ccsr (1.33 KB, patch)
2013-05-12 09:12 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2013-05-05 13:45:10 UTC
Created attachment 17955 [details]
item table cut off in marc view

See attached. When viewing the marc in the opac when using ccsr the items table goes behind the grey border on the right and there is not right to left scrollbar  (not that I want one - but I do want to see the rest of that table).
Comment 1 Owen Leonard 2013-05-10 20:07:35 UTC Comment hidden (obsolete)
Comment 2 Nicole C. Engard 2013-05-11 01:42:01 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2013-05-12 09:12:26 UTC
Created attachment 18089 [details] [review]
[PASSED QA] Bug 10196 - items table partially hidden in marc view in ccsr

In the CCSR theme's OPAC MARC view the table of items is truncated
because the container div is styled with "overflow:hidden." I think the
complete display of information is more important than not seeing a
horizontal scrollbar, so this patch removes the style.

To test, apply the patch and clear your browser cache. View a MARC
detail page for a title which has holdings and confirm that the entire
table can be seen. Test other pages to make sure no unwanted layout
changes have resulted.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
all tests pass

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Simple CSS change, no string changes.
Comment 4 Jared Camins-Esakov 2013-05-12 14:03:32 UTC
This is a 3.10.x-only change, as this problem does not exist on 3.12 or 3.14.
Comment 5 Jared Camins-Esakov 2013-05-13 14:01:55 UTC
With Owen's help I was able to reproduce this problem on master. Resetting version, and pushing shortly.
Comment 6 Jared Camins-Esakov 2013-05-13 14:02:59 UTC
This patch has been pushed to master and 3.12.x.