Bug 10225 - If an item isn't editable, don't show the onclick Edit/Delete menu
Summary: If an item isn't editable, don't show the onclick Edit/Delete menu
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact:
URL:
Whiteboard:
Keywords:
: 6802 10322 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-09 19:07 UTC by Owen Leonard
Modified: 2014-12-07 20:02 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 10225 - If an item isn't editable, don't show the onclick Edit/Delete menu (3.41 KB, patch)
2013-05-09 19:14 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10225 - If an item isn't editable, don't show the onclick Edit/Delete menu (3.45 KB, patch)
2013-05-10 15:46 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[PASSED QA] Bug 10225 - If an item isn't editable, don't show the onclick Edit/Delete menu (3.59 KB, patch)
2013-05-12 09:43 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2013-05-09 19:07:22 UTC
When editing items, if you click anywhere in the table of items you'll be shown a small Edit/Delete menu. This menu should not appear on rows for items which are not editable because of the IndependantBranches setting.
Comment 1 Owen Leonard 2013-05-09 19:14:07 UTC Comment hidden (obsolete)
Comment 2 Nicole C. Engard 2013-05-10 15:46:04 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2013-05-12 09:43:04 UTC
Created attachment 18092 [details] [review]
[PASSED QA] Bug 10225 - If an item isn't editable, don't show the onclick Edit/Delete menu

The user should not be shown edit/delete links when clicking on a row in
additems which they cannot edit because of the IndependantBranches
setting. This patch adds a class to the row to exclude such rows in the
JavaScript onclick handler.

To test:

- Turn IndependantBranches on and edit items for a title which
  has holdings from various branches including your own.
- Click a row for an item which is held by your library. You should see
  the "Edit/Delete" links appear.
- Click a row for an item which is held by another library. No links
  should appear.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
All test pass

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
All tests and QA script pass.
Changes to the templates include no string changes.
Comment 4 Jared Camins-Esakov 2013-05-12 14:09:55 UTC
This patch has been pushed to master and 3.12.x.
Comment 5 Chris Cormack 2013-05-15 21:49:41 UTC
Pushed to 3.10.x and 3.8.x will be in 3.10.6 and 3.8.13
Comment 6 Magnus Enger 2013-05-18 08:05:46 UTC
*** Bug 6802 has been marked as a duplicate of this bug. ***
Comment 7 Katrin Fischer 2013-05-24 10:33:16 UTC
*** Bug 10322 has been marked as a duplicate of this bug. ***