Bug 10241 - Easy analyticals creates two 773 fields. Search/link from host to children is broken
Summary: Easy analyticals creates two 773 fields. Search/link from host to children is...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Bibliographic data support (show other bugs)
Version: master
Hardware: All All
: P4 normal (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-13 23:49 UTC by Elaine Bradtke
Modified: 2016-01-19 04:37 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 10241 - Easy analyticals creates two 773 fields. Search/link from host to children is broken (1.67 KB, patch)
2015-01-15 01:58 UTC, Thomas Wright
Details | Diff | Splinter Review
[SIGNED OFF] Bug 10241 - Easy analyticals creates two 773 fields. Search/link from host to children is broken (1.73 KB, patch)
2015-01-15 06:28 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 10241 - Easy analyticals creates two 773 fields. Search/link from host to children is broken (1.79 KB, patch)
2015-01-15 09:49 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Elaine Bradtke 2013-05-13 23:49:32 UTC
UseControlNumber preference is set to "Don't use" and the EasyAnalyticalRecords preference is set  to 'Display.'

I created a record, and then selected New child record and created an analytic.
Then, following the instructions in the manual Chapter 5 http://es.koha-community.org/manual/3.10/en/cataloging.html#cataloganalytics I linked the analytic to the host item.

This resulted in two 773 fields.  The first (created when adding a new child record contains:

 w Host Record control number 005037189  
  d Place, publisher, and date of publication Milwaukee : Hal Leonard, [2002?]
  z International Standard Book Number 0634038788
  t Title Selections from O brother, where art thou? :

The second 773, created when I linked the child to the parent contains the above, plus

0 Host Biblionumber 19017
9 Host Itemnumber 20551

The search for analytics is driven by the host item number, which is not included in the 773 that is created with a new child record. So you must link the child to the parent.  But why create an additional 773? It looks messy.

Second part possibly not related at all to the above:

When I go to the host item in the staff interface and click on Analytics it says Used in 4 analytics ('4 analytics' is a link: http://kohaadmin-test.efdss.org/cgi-bin/koha/catalogue/search.pl?idx=hi&q=20551

If I click on the link:
 No results found. No results match your search for 'hi,wrdl: 20551' in VWML Test Catalog.

But if I put the host item number 20551  into the search field, it returns the children and the parent record.

Something about the search from analytics is not functioning correctly.
Comment 1 Martin Renvoize 2013-05-17 12:54:50 UTC
I've just been going through the options and if my understanding is correct it would appear there's been a regression somewhere.

I'm sure it used to be that when you enabled EasyAnalytics, then the 'Analyze items' menu option replaced 'New child record' as an option under the 'New' menu in a record display.

With both options present it's very easy to get confused between the two different mutually exclusive procedures for creating analytics.

However.. I do think we should be able to enhance the functionality such that the options are no longer mutually exclusive. I'll open another bug for this as an enhancement.
Comment 2 Katrin Fischer 2015-01-06 23:08:07 UTC
This is from the template for the links:
152             [% IF ( EasyAnalyticalRecords && CAN_user_editcatalogue_edit_catalogue ) %]
153                 <li><a href="/cgi-bin/koha/catalogue/detail.pl?biblionumber=[% biblionumber %]&amp;analyze=1">Analyze items</a></li>
154             [% END %]
155             [% IF CAN_user_editcatalogue_edit_catalogue %]
156                 <li><a href="/cgi-bin/koha/cataloguing/addbiblio.pl?parentbiblionumber=[% biblionumber %]">New child record</a></li>
157             [% END %]

We could easily hide the 'new child record' if EasyAnalytics is turned on - althought it would be nicer to find a way to have both coexist (item level linking and record level linking).
Comment 3 Martin Renvoize 2015-01-07 08:32:47 UTC
Hmm, I'de totlay forgotten about this bug and analytics is now out of my mindspace :(

I'de love to see a more thorough treatment of this allowing for the preferences to be used collaboratively.
Comment 4 Martin Renvoize 2015-01-07 08:36:09 UTC
I did start work on this.. though only to the level of documenting what the expected behaviour for analytics at the marc level should be..

http://wiki.koha-community.org/wiki/Analytics
Comment 5 Martin Renvoize 2015-01-07 09:02:57 UTC
Looks like that page is somewhat out of date compared to our internal one.. I'm just sanitzng and transfering my findings from 2013 onto the community wiki.. alsmost as a sort of RFC for this work
Comment 6 Martin Renvoize 2015-01-07 11:57:37 UTC
I've updated my ramblings and documentatino now:  http://wiki.koha-community.org/wiki/Multipart_Bibliographics

That page links out to three separate pages for each of the possible UseControlNumber combinations.. I need to add in the EasyAnalytics thoughts for each of those specific use cases.
Comment 7 Martin Renvoize 2015-01-07 11:59:16 UTC
For a quick fix however to this particular bug.. Katrins identified the right place in the templates that needs amending.. perhaps one for an Academy student?
Comment 8 Thomas Wright 2015-01-15 01:58:39 UTC Comment hidden (obsolete)
Comment 9 Katrin Fischer 2015-01-15 06:28:34 UTC Comment hidden (obsolete)
Comment 10 Martin Renvoize 2015-01-15 09:49:44 UTC
Created attachment 35294 [details] [review]
[PASSED QA] Bug 10241 - Easy analyticals creates two 773 fields. Search/link from host to children is broken

Hidden 'New child record' if 'EasyAnalytics' is set to display.

Testing plan:

-Turn on 'EasyAnalytics'. Check the drop down menu from the records page
*The drop down menu should include 'Analyze items' and not include 'New child record'

-Turn off 'EasyAnalytics'. Again check the drop down menu from the records page
*The drop down menu should include 'New child record' and not inlucde 'Analyze items'

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 11 Martin Renvoize 2015-01-15 09:50:47 UTC
Cheers Thomas, another bug bites the dust :)
Comment 12 Tomás Cohen Arazi 2015-02-05 17:59:50 UTC
Patch pushed to master.

Thanks Thomas!
Comment 13 Chris Cormack 2015-02-09 20:55:51 UTC
Pushed to 3.18.x will be in 3.18.4 release
Comment 14 Mason James 2015-02-26 03:18:36 UTC
(In reply to Chris Cormack from comment #13)
> Pushed to 3.18.x will be in 3.18.4 release

Pushed to 3.16.x, will be in 3.16.8