Bug 10253 - tax rate only takes 1 decimal point
Summary: tax rate only takes 1 decimal point
Status: RESOLVED DUPLICATE of bug 14541
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on: 12825 13323
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 03:46 UTC by Nicole C. Engard
Modified: 2016-11-09 09:18 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
tax rate preference (20.50 KB, image/png)
2013-05-16 03:46 UTC, Nicole C. Engard
Details
tax rate pull down (14.63 KB, image/png)
2013-05-16 03:47 UTC, Nicole C. Engard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2013-05-16 03:46:50 UTC
Created attachment 18163 [details]
tax rate preference

See attached.  The tax rate where I am is 6.85, but I can't get that to show in the tax pull down. It turns it in to 6.8
Comment 1 Nicole C. Engard 2013-05-16 03:47:06 UTC
Created attachment 18164 [details]
tax rate pull down
Comment 2 Katrin Fischer 2015-01-06 20:26:18 UTC
Still valid, adding Jonathan as the 'tax expert'.
Comment 3 Jonathan Druart 2015-01-07 07:48:48 UTC
This is not fixed by the tax rewrite work (bug 12825).
But it will be very easy to do when all patches will be pushed.
Comment 4 Kyle M Hall 2016-10-20 14:36:17 UTC
As discussed on bug 14541, we shouldn't force the tax rate to *any* arbitrary precision. I just came across a library with a tax right of something like 4.3655 percent!
Comment 5 Jonathan Druart 2016-11-09 09:06:20 UTC
(In reply to Kyle M Hall from comment #4)
> As discussed on bug 14541, we shouldn't force the tax rate to *any*
> arbitrary precision. I just came across a library with a tax right of
> something like 4.3655 percent!

With 4.3655, it would be 0.043655 in DB, but as we store only 4 decimal it will be truncated to 0.0436
We would need to update the DB structure to support such precision.
Comment 6 Jonathan Druart 2016-11-09 09:18:28 UTC

*** This bug has been marked as a duplicate of bug 14541 ***