Bug 10358 - add a syspref to allow BLOCKED patrons to return items, via the SCO
Summary: add a syspref to allow BLOCKED patrons to return items, via the SCO
Status: RESOLVED DUPLICATE of bug 10554
Alias: None
Product: Koha
Classification: Unclassified
Component: Self checkout (show other bugs)
Version: 3.10
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on: 10554
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 11:02 UTC by Bob Birchall
Modified: 2014-11-29 09:09 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10358 - Unable to return items via self check (2.61 KB, patch)
2013-06-03 22:11 UTC, Mason James
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Birchall 2013-05-28 11:02:22 UTC
Using Koha's Self checkout module at /cgi-bin/koha/sco/sco-main.pl in Koha 3.10.4.  System preference 'AllowSelfCheckReturns' is set to allow.
When a patron's barcode is submitted, items on loan are refreshed.  There is a button for renewing the item but no button for return.  Unable to find any facility to return the item.
Comment 1 Mason James 2013-06-02 21:28:18 UTC
(In reply to comment #0)
> Using Koha's Self checkout module at /cgi-bin/koha/sco/sco-main.pl in Koha
> 3.10.4.  System preference 'AllowSelfCheckReturns' is set to allow.
> When a patron's barcode is submitted, items on loan are refreshed.  There is
> a button for renewing the item but no button for return.  Unable to find any
> facility to return the item.


Bob, i have a patch for this...

i'll upload it today
Comment 2 Mason James 2013-06-02 21:36:00 UTC
(In reply to comment #0)
> Using Koha's Self checkout module at /cgi-bin/koha/sco/sco-main.pl in Koha
> 3.10.4.  System preference 'AllowSelfCheckReturns' is set to allow.
> When a patron's barcode is submitted, items on loan are refreshed.  There is
> a button for renewing the item but no button for return.  Unable to find any
> facility to return the item.

fyi: there is some broken workflow in the SCO currently...

currently, if you want to return an item - you must 'renew' it many times, until the items renewal limit has been reached; *only* then are you allowed to return it?!

this patch fixed this problem, and allows an item to be returned, regardless of its renewal status
Comment 3 Mason James 2013-06-02 21:37:11 UTC
> this patch fixed this problem, and allows an item to be returned, regardless
> of its renewal status

... if the 'AllowSelfCheckReturns' syspref is enabled, of course ;)
Comment 4 Mason James 2013-06-03 22:11:15 UTC
Created attachment 18633 [details] [review]
Bug 10358 - Unable to return items via self check

to test, before applying patch…

1/ issue an item to a user,
 set the duedate in the past (2001-01-01) to make this item overdue

2/ attempt to check-in item via SCO, at http://opac/cgi-bin/koha/sco/sco-main.pl
 note a warning message - with no option to return item :/
--------------------------------------
 Item cannot be checked out.
 Sorry, this item cannot be checked out at this station.
--------------------------------------

3/ apply patch

4/ attempt to check-in item via SCO
 note a warning message - now *with* a check-in button

5/ click 'check-in' button
6/ note that item has been returned successfully
Comment 5 Bob Birchall 2013-07-08 03:19:33 UTC
I tested this against 3.10.4, using a borrower with overdues and one with no overdues, and with all three settings of the sys pref.
- When sys pref is set to 'All' both borrowers can return, as expected;
- when sys pref is set to 'Non-Blocked' the borrower with no overdues can return but the borrower with fines cannot return, again as expected.
- When the sys pref is set to 'Don't Allow', neither borrower can return (as expected) however there is an unexpected difference in the screen dialogue:
Case 1, borrower who is blocked receives the message 'Item cannot be checked out' with option only of returning to the Account Summury;
Case 2, borrower who is not blocked receives the same message but has the 'Return Item' button displayed as well as the 'Return' button.  
When 'Return Item' is clicked the item in fact is not returned (respecting the sys pref).  However the display error is likely to confuse users and should be fixed in my opinion.

Unable to sign off.
Comment 6 Katrin Fischer 2014-11-29 09:09:38 UTC

*** This bug has been marked as a duplicate of bug 10554 ***