Bug 10359 - CCSR theme should apply jqTransform after OpacUserJS
Summary: CCSR theme should apply jqTransform after OpacUserJS
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Jared Camins-Esakov
QA Contact: Jonathan Druart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-28 11:44 UTC by Jared Camins-Esakov
Modified: 2014-12-07 20:02 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10359: transform masthead dropdown after user JS for CCSR (1.65 KB, patch)
2013-05-28 11:48 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 10359: transform masthead dropdown after user JS for CCSR (1.70 KB, patch)
2013-05-28 17:46 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 10359: transform masthead dropdown after user JS for CCSR (1.76 KB, patch)
2013-05-29 09:04 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2013-05-28 11:44:04 UTC
Since libraries may want to customize the options in the masthead search dropdown, which is done via dropdown, it would be better if the select box were transformed *after* user javascript was run.
Comment 1 Jared Camins-Esakov 2013-05-28 11:48:51 UTC Comment hidden (obsolete)
Comment 2 Mirko Tietgen 2013-05-28 17:46:34 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2013-05-29 09:04:32 UTC
QA comment:
Just move a js line some lines before.
No regression possible.
Marked as Passed QA.
Comment 4 Jonathan Druart 2013-05-29 09:04:45 UTC
Created attachment 18451 [details] [review]
Bug 10359: transform masthead dropdown after user JS for CCSR

Since libraries may want to customize the options in the masthead search
dropdown, which is done via dropdown, it would be better if the select
box were transformed *after* user javascript was run.

To test:
1) Switch to the CCSR OPAC theme.
2) Add some Javascript to your OpacUserJS that will modify the masthead
   search dropdown, such as:
   $("select[name='idx']").append("<option value='Host-item,wrdl'>Journal title</option>");
3) Note that when you view the OPAC, the results in the dropdown are unchanged.
4) Apply patch.
5) Note that your new option now shows up.
6) Sign off.

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 5 Galen Charlton 2013-05-29 14:46:58 UTC
Pushed to master.  Thanks, Jared!
Comment 6 Tomás Cohen Arazi 2013-06-10 17:19:51 UTC
This patch has been pushed to 3.12.x, will be in 3.12.1.
Comment 7 Bernardo Gonzalez Kriegel 2013-06-10 23:16:11 UTC
Pushed to 3.10.x, will be in 3.10.7