Bug 10458 - Remove obsolete Z3950 module and test
Summary: Remove obsolete Z3950 module and test
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Z39.50 / SRU / OpenSearch Servers (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Marcel de Rooy
QA Contact: Jonathan Druart
URL:
Keywords:
: 10211 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-13 08:25 UTC by Marcel de Rooy
Modified: 2014-12-07 20:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10458: Remove obsolete Z3950 module and test (9.75 KB, patch)
2013-06-13 08:27 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10458: Remove obsolete Z3950 module and test (9.77 KB, patch)
2013-06-14 11:19 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 10458: Remove obsolete Z3950 module and test (9.81 KB, patch)
2013-06-14 12:51 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10458: t/Z3950.t should be removed too (718 bytes, patch)
2013-06-14 12:51 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2013-06-13 08:25:35 UTC
Removes a dead module and test.
Not used and lots of FIXME's in there.
Comment 1 Marcel de Rooy 2013-06-13 08:27:50 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2013-06-14 11:19:00 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2013-06-14 12:50:55 UTC
QA comment:

I agree with this patch. I didn't find any possible regressions.
You forgot the t/Z3950.t file, I will submit a followup.

Marked as Passed QA.
Comment 4 Jonathan Druart 2013-06-14 12:51:12 UTC
Created attachment 19003 [details] [review]
Bug 10458: Remove obsolete Z3950 module and test

Are not used. Contain several FIXMEs.
Removing them makes life easier.

Test plan:
Actually, you cannot test this.
But for confidence: do a Z3950 search in cataloguing and acquisition.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 5 Jonathan Druart 2013-06-14 12:51:15 UTC
Created attachment 19004 [details] [review]
Bug 10458: t/Z3950.t should be removed too

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 6 Jonathan Druart 2013-06-14 12:53:20 UTC
Note: the qa tests don't work with this patch. I find a limitation (commit only deletes files). Thank Marcel for that! :)
Comment 7 Galen Charlton 2013-06-14 15:04:31 UTC
This is high up on my list of favorite types of patches.

Pushed to master.  Thanks, Marcel and Jonathan!
Comment 8 Bernardo Gonzalez Kriegel 2013-07-13 14:44:49 UTC
This has been already pushed to 3.12.x

Pushed to 3.10.x, will be in 3.10.8
Comment 9 Chris Hall 2013-07-18 08:53:41 UTC
Pushed to 3.8.x, will be in 3.8.15
Comment 10 Marcel de Rooy 2013-07-18 10:25:14 UTC
*** Bug 10211 has been marked as a duplicate of this bug. ***