Bug 10480 - Improvements for framework plugins in cataloguing/item editor
Summary: Improvements for framework plugins in cataloguing/item editor
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Marcel de Rooy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 13305 14660
  Show dependency treegraph
 
Reported: 2013-06-17 11:16 UTC by Marcel de Rooy
Modified: 2016-12-05 21:23 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Medium patch
Bot Control: ---
When did the bot last check this: 2013-10-25 00:00:00
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 10480: New cataloging plugin style without redefining (10.49 KB, patch)
2013-06-17 11:22 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: New cataloging plugin style without redefining (10.50 KB, patch)
2013-06-17 13:31 UTC, Marcel de Rooy
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10480: New cataloging plugin style without redefining (10.62 KB, patch)
2013-06-18 08:56 UTC, Nuño López Ansótegui
Details | Diff | Splinter Review
Bug 10480: New cataloging plugin style without redefining (10.86 KB, patch)
2013-06-19 12:08 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: New cataloging plugin style without redefining (10.77 KB, patch)
2013-06-19 14:00 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Followup for additem.pl (no redefines for plugins) (4.35 KB, patch)
2013-06-20 09:14 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Followup for additem.pl (no redefines for plugins) (4.46 KB, patch)
2013-06-20 09:21 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: New module and unit test for framework plugins (24.36 KB, patch)
2014-12-11 11:40 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Use the framework plugin object in cataloguing (34.07 KB, patch)
2014-12-11 11:40 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: EXAMPLE plugin with associated template (8.25 KB, patch)
2014-12-11 11:40 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Remove useless routines and irrelevant pod lines (104.23 KB, patch)
2014-12-11 11:40 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Follow-up for unimarc_field_686a/_700-4.pl (1.79 KB, patch)
2014-12-11 11:40 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: New module and unit test for framework plugins (24.36 KB, patch)
2015-01-14 13:21 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Use the framework plugin object in cataloguing (34.08 KB, patch)
2015-01-14 13:21 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: EXAMPLE plugin with associated template (8.25 KB, patch)
2015-01-14 13:21 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Remove useless routines and irrelevant pod lines (104.24 KB, patch)
2015-01-14 13:21 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Follow-up for unimarc_field_686a/_700-4.pl (1.79 KB, patch)
2015-01-14 13:21 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Remove useless routines and irrelevant pod lines (103.09 KB, patch)
2015-01-15 07:44 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: Follow-up for unimarc_field_686a/_700-4.pl (1.79 KB, patch)
2015-01-15 07:44 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10480: New module and unit test for framework plugins (24.37 KB, patch)
2015-02-20 23:06 UTC, Brendan Gallagher
Details | Diff | Splinter Review
Bug 10480: Use the framework plugin object in cataloguing (34.11 KB, patch)
2015-02-20 23:06 UTC, Brendan Gallagher
Details | Diff | Splinter Review
Bug 10480: EXAMPLE plugin with associated template (8.26 KB, patch)
2015-02-20 23:06 UTC, Brendan Gallagher
Details | Diff | Splinter Review
Bug 10480: Remove useless routines and irrelevant pod lines (103.12 KB, patch)
2015-02-20 23:06 UTC, Brendan Gallagher
Details | Diff | Splinter Review
Bug 10480: Follow-up for unimarc_field_686a/_700-4.pl (1.80 KB, patch)
2015-02-20 23:06 UTC, Brendan Gallagher
Details | Diff | Splinter Review
Bug 10480: New module and unit test for framework plugins (24.43 KB, patch)
2015-03-17 16:15 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10480: Use the framework plugin object in cataloguing (34.16 KB, patch)
2015-03-17 16:15 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10480: EXAMPLE plugin with associated template (8.31 KB, patch)
2015-03-17 16:15 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10480: Remove useless routines and irrelevant pod lines (103.09 KB, patch)
2015-03-17 16:16 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10480: Follow-up for unimarc_field_686a/_700-4.pl (1.85 KB, patch)
2015-03-17 16:16 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 10480: New module and unit test for framework plugins (24.52 KB, patch)
2015-04-16 11:42 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 10480: New module and unit test for framework plugins (24.52 KB, patch)
2015-04-16 11:42 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 10480: Use the framework plugin object in cataloguing (34.24 KB, patch)
2015-04-16 11:42 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 10480: EXAMPLE plugin with associated template (8.40 KB, patch)
2015-04-16 11:42 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 10480: Remove useless routines and irrelevant pod lines (103.25 KB, patch)
2015-04-16 11:42 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 10480: Follow-up for unimarc_field_686a/_700-4.pl (1.94 KB, patch)
2015-04-16 11:42 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 10480: (QA followup) hide the EXAMPLE.pl plugin (1.76 KB, patch)
2015-04-16 18:27 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2013-06-17 11:16:03 UTC
From bug 9921, Galen:
All the more reason to stick to our coding guidelines, if the additional warning messages in the log annoys somebody enough to inspire them to fix that issue with the cataloging plugins, then. :)

I am submitting a proposal here.
May not be perfect yet, but we loose the redefines.
Comment 1 Marcel de Rooy 2013-06-17 11:22:21 UTC Comment hidden (obsolete)
Comment 2 Marcel de Rooy 2013-06-17 13:01:32 UTC
adds the way => changes the way
Comment 3 Marcel de Rooy 2013-06-17 13:31:27 UTC Comment hidden (obsolete)
Comment 4 Nuño López Ansótegui 2013-06-18 08:56:42 UTC Comment hidden (obsolete)
Comment 5 Marcel de Rooy 2013-06-19 12:08:29 UTC Comment hidden (obsolete)
Comment 6 Marcel de Rooy 2013-06-19 14:00:44 UTC Comment hidden (obsolete)
Comment 7 Marcel de Rooy 2013-06-19 14:02:32 UTC
Could have a signoff again, since I amended my patch.
Note that git may have some trouble with diacritics in the commit message..
Comment 8 Marcel de Rooy 2013-06-20 08:49:06 UTC
I just realize that we do need to make a similar change in additem.pl (of course..) So indeed, it was not perfect yet.
Comment 9 Marcel de Rooy 2013-06-20 09:14:27 UTC Comment hidden (obsolete)
Comment 10 Marcel de Rooy 2013-06-20 09:21:22 UTC Comment hidden (obsolete)
Comment 11 I'm just a bot 2013-10-24 19:25:40 UTC
Patch applied cleanly, go forth and signoff
Comment 12 Marcel de Rooy 2014-10-21 12:34:19 UTC
Still want to proceed on this in another direction.
Comment 13 Marcel de Rooy 2014-12-11 11:39:33 UTC
(In reply to M. de Rooy from comment #12)
> Still want to proceed on this in another direction.

This took some more time than I hoped for. But will submit them now, based on the concept of two anynomous subroutines.
Comment 14 Marcel de Rooy 2014-12-11 11:40:22 UTC Comment hidden (obsolete)
Comment 15 Marcel de Rooy 2014-12-11 11:40:26 UTC Comment hidden (obsolete)
Comment 16 Marcel de Rooy 2014-12-11 11:40:29 UTC Comment hidden (obsolete)
Comment 17 Marcel de Rooy 2014-12-11 11:40:33 UTC Comment hidden (obsolete)
Comment 18 Marcel de Rooy 2014-12-11 11:40:37 UTC Comment hidden (obsolete)
Comment 19 Marcel de Rooy 2014-12-11 11:44:21 UTC
I will add see also-reports to convert old style plugins to new style plugins for marc21, normarc and unimarc.
This can be tested and handled separately however.
Comment 20 Marcel de Rooy 2015-01-14 13:21:25 UTC Comment hidden (obsolete)
Comment 21 Marcel de Rooy 2015-01-14 13:21:29 UTC Comment hidden (obsolete)
Comment 22 Marcel de Rooy 2015-01-14 13:21:34 UTC Comment hidden (obsolete)
Comment 23 Marcel de Rooy 2015-01-14 13:21:38 UTC Comment hidden (obsolete)
Comment 24 Marcel de Rooy 2015-01-14 13:21:42 UTC Comment hidden (obsolete)
Comment 25 Marcel de Rooy 2015-01-14 13:22:18 UTC
Rebased. Anyone willing to help getting this further?
Comment 26 Marcel de Rooy 2015-01-15 07:44:22 UTC Comment hidden (obsolete)
Comment 27 Marcel de Rooy 2015-01-15 07:44:27 UTC Comment hidden (obsolete)
Comment 28 Brendan Gallagher 2015-02-20 23:06:13 UTC Comment hidden (obsolete)
Comment 29 Brendan Gallagher 2015-02-20 23:06:20 UTC Comment hidden (obsolete)
Comment 30 Brendan Gallagher 2015-02-20 23:06:27 UTC Comment hidden (obsolete)
Comment 31 Brendan Gallagher 2015-02-20 23:06:35 UTC Comment hidden (obsolete)
Comment 32 Brendan Gallagher 2015-02-20 23:06:41 UTC Comment hidden (obsolete)
Comment 33 Brendan Gallagher 2015-02-20 23:13:06 UTC
Notes - 

Followed test plan and recommendations.  I couldn't find anything wrong with it.  It took me a long time to get through it - not sure if I am just slow or what - so heads up for QA (I poked at parts for a few differnt days .  As I went through it I didn't really find an extra area that needed checking.  So QA should be able to follow plans forward.  Also read through the code and didn't find anything that was out of place for code.

Thanks,
Brendan
Comment 34 Marcel de Rooy 2015-02-21 13:21:39 UTC
(In reply to Brendan Gallagher from comment #33)
> Followed test plan and recommendations.  I couldn't find anything wrong with
> it.  It took me a long time to get through it - not sure if I am just slow
> or what - so heads up for QA (I poked at parts for a few differnt days .  As
> I went through it I didn't really find an extra area that needed checking. 
> So QA should be able to follow plans forward.  Also read through the code
> and didn't find anything that was out of place for code.

Thanks!
Comment 35 Katrin Fischer 2015-03-05 07:13:41 UTC
I think this probably shouldn't go on to the stable branches as it would break custom plugins the library might have. As the title says "improvements" switching to "enh" - but I know it's not quite.
Comment 36 Marcel de Rooy 2015-03-05 07:34:13 UTC
(In reply to Katrin Fischer from comment #35)
> I think this probably shouldn't go on to the stable branches as it would
> break custom plugins the library might have. 

Do you have any reasons to say that it would break custom plugins? Part of some complexity here is backward compatibility.
BTW I agree that this is not targeted for the stable branches in the first place.
Comment 37 Jonathan Druart 2015-03-17 16:15:15 UTC Comment hidden (obsolete)
Comment 38 Jonathan Druart 2015-03-17 16:15:31 UTC Comment hidden (obsolete)
Comment 39 Jonathan Druart 2015-03-17 16:15:45 UTC Comment hidden (obsolete)
Comment 40 Jonathan Druart 2015-03-17 16:16:07 UTC Comment hidden (obsolete)
Comment 41 Jonathan Druart 2015-03-17 16:16:27 UTC Comment hidden (obsolete)
Comment 42 Jonathan Druart 2015-03-17 16:20:23 UTC
Great work Marcel!
I did not find any regression and the code looks better than before. I really would like to see this one moving forward to motivate you to continue the job :)
However I would like to get another pair of eyes on it, that's why I don't change the status for now.

Just one question: The EXAMPLE plugin should be removed (or not pushed) or hidden in the dropdown list, don't you think?
Comment 43 Marcel de Rooy 2015-03-17 20:30:15 UTC
(In reply to Jonathan Druart from comment #42)
> I did not find any regression and the code looks better than before. I
> really would like to see this one moving forward to motivate you to continue
> the job :)
> However I would like to get another pair of eyes on it, that's why I don't
> change the status for now.
Thanks for testing.

> Just one question: The EXAMPLE plugin should be removed (or not pushed) or
> hidden in the dropdown list, don't you think?
It is some kind of documentation; also easy to copy and extend it etc.
But we could certainly hide in the dropdown list. That would be a trivial follow-up.
Comment 44 Kyle M Hall 2015-04-16 11:42:11 UTC Comment hidden (obsolete)
Comment 45 Kyle M Hall 2015-04-16 11:42:29 UTC
Created attachment 37949 [details] [review]
[PASSED QA] Bug 10480: New module and unit test for framework plugins

This patch introduces the Koha::FrameworkPlugin object to Koha.
This object supports the current "old-style" plugins while adding a new
style based on the concept of two anynomous subroutines for building and
launching.

I will summarize the advantages of this new approach, justifying the
additional lines of code in this patch:

[1] Centralizing the code for building and launching plugins.
[2] Extensive unit testing: this was not possible before.
[3] Simplicity: Only define what you need in the plugin.
    A follow-up patch will delete 1500 lines with *empty* routines.
[4] Make it possible to restore the warnings pragma for all plugins.
    New style plugins do no longer depend on redefinition.
[5] Event binding moved from HTML attributes moved to jQuery code.
    This separates behavior and presentation.
[6] Much more documentation, including EXAMPLE plugin in follow-up.
[7] Improved error handling.
[8] Usability: property noclick tells you if plugin's buttonDot is active.
[9] More events supported: Change, keyboard/mouse events. See EXAMPLE.

NOTE ON EXAMPLE PLUGIN:
The example plugin is added in the third patch of this report. Since
it is new style, it can be used only after we start using this object. It
also contains an example for a keypress and mouseover event.

NOTE ON ITEM PLUGINS:
Old style plugins for items contain an additional parameter in the js
functions for Blur, Focus and Change. This distinction has no actual use
and is resolved for new plugins in the object code. When converting
item plugins, this minor correction will be addressed. In the meantime
old style item plugins behave as expected.

TEST PLAN:
Run the new test t/db_dependent/FrameworkPlugin.t
At this point in time, you do not need to do anything more. Follow-up
patches will incorporate the object in real-life Koha and provide
additional test plans.

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 46 Kyle M Hall 2015-04-16 11:42:36 UTC
Created attachment 37950 [details] [review]
[PASSED QA] Bug 10480: Use the framework plugin object in cataloguing

This patch implements the use of Koha::FrameworkPlugin in Cataloguing,
Authorities, Acquisition, Serials and Tools.

The main change is architectural: see the commit message of the previous
patch. No changes in behavior are expected, but the support of new events
may provide additional functionality in the future. Some small bugs are
resolved along the way.

The change primarily focuses on the MARC and items editor in Cataloguing.
But the MARC editor for Authorities and the item editor in Acquisition,
Serials and Tools are touched too. This commit message gives some comments
per module.

NOTE FOR CATALOGUING:
A new plugin without popup (or other click event code) now shows the title
No popup when hovering over the tag editor image. The image alerts the
user on a plugin, the title tells about its status. The noclick property
allows for further style modifications in the template. Note that a
follow-up patch will clean up the old style plugins too with the same
effect.

Some additional code in cataloging.js makes it possible to clone subfields
with plugins (although only theoretically useful). The clones use the
same javascript functions but event.data contains an updated id.
This effectively resolves bug 13306. Note that if old plugins do not use
the javascript parameter for the id but the perl variable, cloning does
still operate on the wrong field (with and without this patch set).

In the absence of report 12176 in master, it is not yet necessary to modify
additem.tt. When it gets pushed, it should be an easy rebase.
New style item plugins will no longer need an extra parameter. (The code in
the FrameworkPlugin object actually takes care of that.)

NOTE FOR AUTHORITIES:
This patch also adds class name tag_editor to the buttonDot anchors. This
effectively makes the same tag editor image appear as in Cataloguing.
Futhermore it removes the button from the tab sequence if there is no click
event (really effective after conversion to the new style, since the old
style plugins contain empty onclicks and launchers).
Both small adjustments increase consistency between auth and bib edits.

NOTE FOR ACQUISITION:
In Acquisition two scripts use an item editor, but in a different way.
The scripts addorderiso2709 and neworderempty both rely on the routine
PrepareItemrecordDisplay in C4::Items, but neworderempty creates item
blocks dynamically via an ajax call to services/itemrecorddisplay.pl.

In order to make the dynamic item blocks work with plugins, some code
changes were needed in additem.js. (Normally the event binding is done
at document ready time; now it must be done later.)

At this moment the routine in Items.pm contains the html tags, and this
makes changes to the following templates not necessary for now:
* acqui/addorderiso2709.tt
* services/itemrecorddisplay.tt
Report 13397 has been opened to address moving the html to the templates.

NOTE FOR SERIALS:
Script serial-edit relies also on C4::Items (just as in Acquisition).
This makes changes to serials/serials-edit.tt not necessary for now.

NOTE FOR TOOLS:
The current code in tools/batchMod.pl allows the use of plugins for batch
modification of items. This patch just converts that code to use the new
object. Most item plugins however may not be very useful for operating on
multiple items at once.

PERFORMANCE:
I have benchmarked build_tabs in addbiblio to see how especially the
additional processing of the javascript in the FrameworkPlugin object
would impact performance. Testing default MARC21 framework with 8 plugins
gave the following figures:
- Old situation: 851 ms
- New situation: 942 ms (+10,7%)
- New situation after plugin cleanup: 881 ms (+3,4%)
Note also that adding lines for event binding is compensated by removing
lines for unused events. Page load should essentially be the same.

TEST PLAN:
Suggestion: If you also apply the next patch with the EXAMPLE plugin, you
can test with a rather harmless plugin (with popup) on various places :)
But your test should also include old style plugins, with[out] popups.

If you want to test a new plugin without popup, rename/remove Click$id
in the javascript code of the $builder definition (temporarily).

[1] Test Cataloguing:
    - Add/Edit biblio. Try plugins with and without popup.
    - Add/Edit items. (EXAMPLE can be used as an item plugin with popup.)
    - Clone a subfield with plugin (use EXAMPLE): Verify that the plugin
      works on both original and clone with the respective field values.
      Is the value put back in the right field too?
[2] Test Authorities:
    Edit an authority record. Try plugins with an without popup.
[3] Test Acquisition:
    Set system preference AcqCreateItem to "placing an order".
    Check the item editor in the following two places:
    a- addorderiso2709: Open a basket, add an order from a staged file.
       Select a file, click Add orders, and go to tab Item information.
    b- neworderempty: Open a basket, add an order from a new empty record.
[4] Test Serials:
    Check the item editor on serials-edit. Go to subscription detail.
    Click Receive. Choose "Click to add item". (Note that this subscription
    should create an item record when receiving this serial.)
[5] Test Tools:
    Check the item editor for batch item modification. Enter a few valid
    barcodes and press Continue to reach the item editor.

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 47 Kyle M Hall 2015-04-16 11:42:39 UTC
Created attachment 37951 [details] [review]
[PASSED QA] Bug 10480: EXAMPLE plugin with associated template

The EXAMPLE plugin helps you to create a new style framework plugin by
providing a simple working example and additional documentation for
developers.

Test plan:
[1] Connect the EXAMPLE plugin to one or more fields.
[2] Try the following events:
    a- Focus: If the field is empty, it should put EXAMPLE: into it.
    b- MouseOver: If the field is empty and you move your mouse over it,
       it should have the same effect as Focus.
    c- Change: Edit the field in the editor and tab out of it, the color
       of the text should toggle (randomly) between red, green and blue.
    d- KeyPress: If you edit the field and you type @, it should give AT.
    e- Click: Click on the tag editor. Change the value in the popup.
       If you press OK, the field should be changed.
[3] Would the documentation in the perl script help you to create a plugin?

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 48 Kyle M Hall 2015-04-16 11:42:41 UTC
Created attachment 37952 [details] [review]
[PASSED QA] Bug 10480: Remove useless routines and irrelevant pod lines

This patch makes the following cleanup actions for all plugins:

1- Remove sub plugin_parameters. This function is not used.
2- Remove empty plugin or empty plugin_javascript subs.
3- Remove empty Blur, Clic or Focus routines from javascript.
4- Remove pod lines (copy-pasta) only referring to the 3 plugin subs.
5- Remove the last 1; line. It is no longer needed.

Test plan:
Run the unit test t/db_dependent/FrameworkPlugins.t
Test some cataloguing plugins in addbiblio.
Test some item plugins in additem and neworderempty.

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
I also checked the syntax of all plugins with perl -c.
And checked the pod (if any) with podchecker: Two files still produce a
warning; the follow-up deals with them: unimarc_field_686a/_700-4.pl.

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 49 Kyle M Hall 2015-04-16 11:42:44 UTC
Created attachment 37953 [details] [review]
[PASSED QA] Bug 10480: Follow-up for unimarc_field_686a/_700-4.pl

This patch fixes the pod errors on those two files by removing the pod
section that actually does not add anything useful.

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 50 Tomás Cohen Arazi 2015-04-16 18:27:50 UTC
Created attachment 37983 [details] [review]
Bug 10480: (QA followup) hide the EXAMPLE.pl plugin

The EXAMPLE.pl plugin remains on the source tree for documentation
purposes only, and shouldn't be listed when editing both biblio and
authority cataloguing frameworks.

Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 51 Tomás Cohen Arazi 2015-04-16 18:37:22 UTC
Enhancement pushed to master.

Great work Marcel!
Comment 52 Marcel de Rooy 2015-04-16 19:51:28 UTC
(In reply to Tomás Cohen Arazi from comment #51)
> Enhancement pushed to master.

And thanks for your follow-up.
Comment 53 Jonathan Druart 2015-05-26 13:29:11 UTC
I found a bug:
1/ Open the console
2/ Go on the new order page
3/ TypeError: events is null
for(i=0; i<events.length; i++) {
additem.js (ligne 176, col. 13)

I suppose it happens when none of the fields use a plugin
Comment 54 Marcel de Rooy 2015-06-04 07:32:15 UTC
(In reply to Jonathan Druart from comment #53)
> I found a bug:
> 1/ Open the console
> 2/ Go on the new order page
> 3/ TypeError: events is null
> for(i=0; i<events.length; i++) {
> additem.js (ligne 176, col. 13)
> 
> I suppose it happens when none of the fields use a plugin

Thanks for reporting. See bug 14327.