Bug 10514 - Add item link on acquisitions add item is too small
Summary: Add item link on acquisitions add item is too small
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
: 9539 (view as bug list)
Depends on:
Blocks: 10576
  Show dependency treegraph
 
Reported: 2013-06-28 10:22 UTC by Liz Rea
Modified: 2014-12-07 20:02 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10514 - make the add item link more noticeable when adding items to orders (2.44 KB, patch)
2013-06-28 11:02 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 10514 - make the add item link more noticeable when adding items to orders (2.51 KB, patch)
2013-07-09 13:58 UTC, Jonathan Druart
Details | Diff | Splinter Review
screenshot (11.67 KB, image/png)
2013-07-10 21:30 UTC, Katrin Fischer
Details
Bug 10514 - make the add item link more noticeable when adding items to orders (2.69 KB, patch)
2013-07-11 02:27 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 10514 [Alternate] Add item link on acquisitions add item is too small (3.57 KB, patch)
2013-07-11 14:34 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 10514 [Alternate] Add item link on acquisitions add item is too small (3.81 KB, patch)
2013-07-11 21:16 UTC, Liz Rea
Details | Diff | Splinter Review
[PASSED QA] Bug 10514 [Alternate] Add item link on acquisitions add item is too small (4.06 KB, patch)
2013-07-11 22:09 UTC, Katrin Fischer
Details | Diff | Splinter Review
screenshot - display using alternate patch (6.64 KB, image/png)
2013-07-11 22:11 UTC, Katrin Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2013-06-28 10:22:28 UTC
I have had at least 3 libraries totally miss the "add" link when adding an item to an order in acquisitions, which I take as a sign that it should be made bigger.
Comment 1 Liz Rea 2013-06-28 11:02:49 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2013-07-09 13:58:04 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2013-07-09 14:00:39 UTC
*** Bug 9539 has been marked as a duplicate of this bug. ***
Comment 4 Katrin Fischer 2013-07-10 21:30:28 UTC
Created attachment 19531 [details]
screenshot

Hi Liz,

I totally agree that we need the links to stand out more, but I am not sold on the idea to make the font bigger. With the CSS in the top of the page it's also hard to change it back if you wanted to. Maybe we could use buttons? 

Another problem I spotted while looking at this bit of code: as it stands right now, those links are not translatable! It's a problem before and after your patch and can go onto another bug. But if you want to try - using a concatenated Javascript string with _() in the right place should fix it.

But failing for wrong capitalization - sorry!
Comment 5 Liz Rea 2013-07-11 02:15:13 UTC
I don't like buttons there, that's not the end of the page and it just feels weird to me. 

The CSS is in the staff global css file, so not sure what you're getting at?

As for it not being translatable - that predates this patch. Maybe I'll fix it though.

For now, I'll probably just fix the capitalisation. ;)

Liz
Comment 6 Liz Rea 2013-07-11 02:27:30 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2013-07-11 05:37:41 UTC
You are right about the CSS - sorry!
Comment 8 Owen Leonard 2013-07-11 14:34:32 UTC Comment hidden (obsolete)
Comment 9 Liz Rea 2013-07-11 21:16:34 UTC Comment hidden (obsolete)
Comment 10 Katrin Fischer 2013-07-11 22:09:37 UTC
Created attachment 19585 [details] [review]
[PASSED QA] Bug 10514 [Alternate] Add item link on acquisitions add item is too small

This alternate patch for Bug 10514 converts the "Add" and "Clear" links
to the standard "submit/cancel" format inside a fieldset. This gives
them a little more visual weight to solve the problem in a differnt way.

Based on the changes made by Liz Rea and Jonathan Druart. Same test
plan:

create a basket
add a record to it
scroll down - the link to add item and cancel should both be more
prominent now.
Click "Add item" - it should add an item.

Signed-off-by: Liz Rea <liz@catalyst.net.nz>
I still feel weird about the button, but as two people have said they'd rather have the button, I'm alright with it I guess.
Really what I want is people to notice it's there and click it at the appropriate time. I hope this will help that issue.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script.
Leaves the translation problems, but that needs more work and is
out of the scope of this bug.
Tested Add and Update functionality works correctly.
Comment 11 Katrin Fischer 2013-07-11 22:11:14 UTC
Created attachment 19586 [details]
screenshot - display using alternate patch
Comment 12 Katrin Fischer 2013-07-11 22:15:51 UTC
I have attached 2 screenshots to compare the results of both patches. I personally like the second a bit better, because it fits how we do things in other places. 

There was also a suggestion to add some additional text to the form on IRC:
(23:28:47) rangi: id like some text
(23:28:51) rangi: right below Item
(23:29:15) rangi: (Fill in the following form and click add, to add 1 item to your order, do this as many times as needed)
Comment 13 Galen Charlton 2013-07-12 23:40:17 UTC
Pushed to master.  Thanks, everybody!
Comment 14 Tomás Cohen Arazi 2013-07-25 15:18:36 UTC
This patch has been pushed to 3.12.x, will be in 3.12.3.

Thanks everyone involved!
Comment 15 Bernardo Gonzalez Kriegel 2013-08-04 22:51:03 UTC
Pushed to 3.10.x, will be in 3.10.10
Comment 16 Chris Hall 2013-08-20 09:09:05 UTC
Pushed to 3.8.x, will be in 3.8.17