Bug 10516 - Improve titles, breadcrumbs, and confirmation messages for Z39.50 server adds and updates
Summary: Improve titles, breadcrumbs, and confirmation messages for Z39.50 server adds...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact:
URL:
Keywords:
: 9849 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-28 19:06 UTC by Owen Leonard
Modified: 2014-12-07 20:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10516 - Improve titles, breadcrumbs, and confirmation messages for Z39.50 server adds and updates (4.55 KB, patch)
2013-07-19 20:14 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 10516 - Improve titles, breadcrumbs, and confirmation messages for Z39.50 server adds and updates (4.56 KB, patch)
2013-07-19 21:19 UTC, Liz Rea
Details | Diff | Splinter Review
[PASSED QA] Bug 10516 - Improve titles, breadcrumbs, and confirmation messages for Z39.50 server adds and updates (4.67 KB, patch)
2013-07-21 09:52 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 10516 - Follow up - Fixing capitalization (1.80 KB, patch)
2013-07-21 09:52 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 10516 - Follow up - Fixing capitalization (1.88 KB, patch)
2013-07-21 23:19 UTC, Liz Rea
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2013-06-28 19:06:28 UTC
The template for adding and updating a Z39.50 server currently shows the same message for adds and updates. It would be more clear if it showed one message for adds and one for updates.
Comment 1 Owen Leonard 2013-07-19 20:14:54 UTC Comment hidden (obsolete)
Comment 2 Liz Rea 2013-07-19 21:19:47 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2013-07-21 09:52:31 UTC
Created attachment 19832 [details] [review]
[PASSED QA] Bug 10516 - Improve titles, breadcrumbs, and confirmation messages for Z39.50 server adds and updates

The template for adding/editing Z39.50 servers shows the same title,
breadcrumbs, etc. for add and edit operations. This patch creates
separate text for each case.

To test, try both adding and editing a Z39.50 server. The page title,
breadcrumb, and heading should correctly reflect the operation you
perform.

Signed-off-by: Liz Rea <wizzyrea@gmail.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Works nicely and all strings are translatable.
Comment 4 Katrin Fischer 2013-07-21 09:52:48 UTC Comment hidden (obsolete)
Comment 5 Liz Rea 2013-07-21 23:19:25 UTC
Created attachment 19842 [details] [review]
Bug 10516 - Follow up - Fixing capitalization

Fix capitalization on submit buttons when deleting
a Z39.50 server.

- Delete this Server
- Do Not Delete

I think the "Do not delete" should maybe even be a cancel
link to be more consistent with how Koha displays this
kind of dialog in other places.

Signed-off-by: Liz Rea <wizzyrea@gmail.com>
fixes capitalisation, tool stil works
Comment 6 Katrin Fischer 2013-07-22 16:44:03 UTC
Thx Liz!
Comment 7 Katrin Fischer 2013-07-22 16:47:53 UTC
Switching back to passed QA after checking with Galen.
Comment 8 Galen Charlton 2013-07-22 18:47:55 UTC
(In reply to Liz Rea from comment #5)
> I think the "Do not delete" should maybe even be a cancel
> link to be more consistent with how Koha displays this
> kind of dialog in other places.

I agree, but I'm content to leave that to a follow-up.
Comment 9 Galen Charlton 2013-07-22 18:48:20 UTC
Pushed to master.  Thanks, Owen!
Comment 10 Tomás Cohen Arazi 2013-08-16 13:26:06 UTC
This patch has been pushed to 3.12.x, will be in 3.12.4.

Thanks Owen!
Comment 11 Bernardo Gonzalez Kriegel 2013-09-13 22:51:34 UTC
Pushed to 3.10.x, will be in 3.10.11
Comment 12 Chris Hall 2013-09-17 07:51:15 UTC
Pushed to 3.8.x, will be in 3.8.18
Comment 13 Magnus Enger 2013-09-25 09:55:56 UTC
*** Bug 9849 has been marked as a duplicate of this bug. ***