Bug 10562 - Improve Leader06 Type Labels in MARC21slim2OPACResults.xsl
Summary: Improve Leader06 Type Labels in MARC21slim2OPACResults.xsl
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Owen Leonard
QA Contact:
URL:
Keywords:
: 9706 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-10 06:07 UTC by David Cook
Modified: 2019-06-06 17:45 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10562: Improve Leader06 Type Labels in MARC21slim2OPACResults.xsl (53.48 KB, patch)
2018-06-29 16:49 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 10562: Improve Leader06 Type Labels in MARC21slim2OPACResults.xsl (53.54 KB, patch)
2019-01-11 19:44 UTC, Charles Farmer
Details | Diff | Splinter Review
Bug 10562: Improve Leader06 Type Labels in MARC21slim2OPACResults.xsl (53.60 KB, patch)
2019-01-11 19:51 UTC, Charles Farmer
Details | Diff | Splinter Review
Bug 10562: Improve Leader06 Type Labels in MARC21slim2OPACResults.xsl (53.69 KB, patch)
2019-01-20 14:42 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description David Cook 2013-07-10 06:07:09 UTC
Within the $DisplayOPACiconsXSLT block in MARC21slim2OPACResults.xsl, we're mapping fixed field data to non-standard human-readable labels. 

While I think the non-standard labels we use are far more useful for users than the standard labels supplied by the LoC, I think that ours, at least in the case of position 6 of the Leader, are not entirely accurate.

Here are the actual mappings (from http://www.loc.gov/marc/bibliographic/bdleader.html):
a - Language material
c - Notated music
d - Manuscript notated music
e - Cartographic material
f - Manuscript cartographic material
g - Projected medium
i - Nonmusical sound recording
j - Musical sound recording
k - Two-dimensional nonprojectable graphic
m - Computer file
o - Kit
p - Mixed materials
r - Three-dimensional artifact or naturally occurring object
t - Manuscript language material
 
Below, I show our basic mappings in Koha (plus add my suggestion in brackets behind it)

a => Book [Text]
c => Score
d => Score
e => Map
f => Map
g => Visual Material [Film]
i => Sound
j => Music
k => Visual Material [Picture]
m => Computer File
o => Kit
p => Mixed Materials
r => Visual Material [Object]
t => Book [Text]
Comment 1 Owen Leonard 2018-06-29 16:49:34 UTC Comment hidden (obsolete)
Comment 2 Charles Farmer 2019-01-11 19:44:26 UTC Comment hidden (obsolete)
Comment 3 Charles Farmer 2019-01-11 19:44:57 UTC
Patch wouldn't apply anymore, made a small rebase

Needs Signoff
Comment 4 Charles Farmer 2019-01-11 19:51:21 UTC
Created attachment 83823 [details] [review]
Bug 10562: Improve Leader06 Type Labels in MARC21slim2OPACResults.xsl

This patch takes the suggestions in Bug 10562 and implements those
changes in MARC21slim2OPACResults.xsl. This patch also makes the
following changes:

 - De-duplicate famfamfam icons: Remove the /silk subdirectory and move
   non-duplicates to famfamfam/; Correct paths to these images in
   templates and CSS
 - Improve the granularity of some material type icon choices: Show
   "Film," "Picture," or "Object" instead of "Visual material."
 - Remove unnecessary title attributes from material type images
 - Implement the kind of changes made in Bug 18235, "Add classes to
   material type icons on result lists and detail pages"

Signed-off-by: Charles Farmer <charles.farmer@inLibro.com>
Comment 5 Katrin Fischer 2019-01-20 14:42:56 UTC
Created attachment 84254 [details] [review]
Bug 10562: Improve Leader06 Type Labels in MARC21slim2OPACResults.xsl

This patch takes the suggestions in Bug 10562 and implements those
changes in MARC21slim2OPACResults.xsl. This patch also makes the
following changes:

 - De-duplicate famfamfam icons: Remove the /silk subdirectory and move
   non-duplicates to famfamfam/; Correct paths to these images in
   templates and CSS
 - Improve the granularity of some material type icon choices: Show
   "Film," "Picture," or "Object" instead of "Visual material."
 - Remove unnecessary title attributes from material type images
 - Implement the kind of changes made in Bug 18235, "Add classes to
   material type icons on result lists and detail pages"

Signed-off-by: Charles Farmer <charles.farmer@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Katrin Fischer 2019-01-20 14:43:19 UTC
I really like the text change from "book" to "text".
Comment 7 Nick Clemens 2019-01-28 16:08:03 UTC
Awesome work all!

Pushed to master for 19.05
Comment 8 Martin Renvoize 2019-02-01 15:05:31 UTC
Pushed to 18.11.x for 18.11.03
Comment 9 Katrin Fischer 2019-02-05 06:39:35 UTC
*** Bug 9706 has been marked as a duplicate of this bug. ***
Comment 10 Jesse Maseto 2019-02-06 18:00:54 UTC
Merge conflict with 18.05.x. Please rebase if needed for 18.05.x.