Bug 10650 - export merge-record.inc javascript into a file
Summary: export merge-record.inc javascript into a file
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Target Milestone: ---
Assignee: Fridolin SOMERS
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 9755
Blocks: 10648
  Show dependency treegraph
 
Reported: 2013-07-26 13:53 UTC by Fridolin SOMERS
Modified: 2014-12-07 20:02 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10650 - export merge-record.inc javascript into a file (13.23 KB, patch)
2013-07-26 14:36 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10650 - export merge-record.inc javascript into a file (13.33 KB, patch)
2013-09-09 13:34 UTC, Owen Leonard
Details | Diff | Splinter Review
[PASSED QA] Bug 10650 - export merge-record.inc javascript into a file (13.39 KB, patch)
2013-09-10 20:50 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2013-07-26 13:53:55 UTC
Bug 9755 added a refactoring of records merge adding the include merge-record.inc. This include contains a block "mergejs" containing all JavaScript code that was in merge.tt.
I propose to export this code into a js file.
These are some reasons : a js file is cached by browser and development is better because editors uses the JavaScript syntax coloring.
Comment 1 Fridolin SOMERS 2013-07-26 14:36:22 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2013-09-09 13:34:10 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2013-09-10 20:50:40 UTC
Created attachment 20975 [details] [review]
[PASSED QA] Bug 10650 - export merge-record.inc javascript into a file

Bug 9755 added a refactoring of records merge adding the include
merge-record.inc. This include contains a block "mergejs" containing all
JavaScript code that was in merge.tt.
This patch exports this code into a js file.
Translatable strings contained in this file are in
merge-record-strings.inc.

Test plan :
- Put two records is a list
- Go to this list and check the two records
- Click on "Merge selected"
- Click on next
- Go to second source record
- Click on a repeatable field
=> The field is added to destination record
- Click on a subfield of a field existing in destination record
=> The subfield is added to destination record
- Click on a non repeatable field existing in destination record
=> You get an alert and field is not added
- Click on a subfield of a field not existing in destination record
=> You get an alert and subfield is not added
- Click on Merge
=> Records are merged

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes tests and test plan, no regressions found.
Comment 4 Galen Charlton 2013-09-16 16:18:00 UTC
Pushed to master.  Thanks, Fridolyn!