Bug 10745 - More fun on translation bug with XSLT subfieldSelect parameters
Summary: More fun on translation bug with XSLT subfieldSelect parameters
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bernardo Gonzalez Kriegel
QA Contact: Marcel de Rooy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-16 19:49 UTC by Bernardo Gonzalez Kriegel
Modified: 2014-12-07 20:03 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10745 - More fun on translation bug with XSLT subfieldSelect parameters (7.19 KB, patch)
2013-08-16 20:27 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 10745 - More fun on translation bug with XSLT subfieldSelect parameters (7.35 KB, patch)
2013-08-22 12:15 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10745 - More fun on translation bug with XSLT subfieldSelect parameters (7.37 KB, patch)
2013-08-22 14:58 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Bernardo Gonzalez Kriegel 2013-08-16 19:49:32 UTC
Some more cases as the ones solved on Bug 6278, now on NORMARCslim2intranetDetail.xsl and MARC21slim2intranetDetail.xsl
Comment 1 Bernardo Gonzalez Kriegel 2013-08-16 20:27:32 UTC Comment hidden (obsolete)
Comment 2 Marcel de Rooy 2013-08-22 12:15:32 UTC Comment hidden (obsolete)
Comment 3 Marcel de Rooy 2013-08-22 12:17:49 UTC
QA Comment:
I know the author of the 6278 patch :)
Since this construct works and is in the current code, we are making a consistent use of this workaround.
Moving it to Passed QA
Comment 4 Katrin Fischer 2013-08-22 14:49:35 UTC
Could we please get another sign-off on this one? :)
Comment 5 Jared Camins-Esakov 2013-08-22 14:58:06 UTC
Created attachment 20565 [details] [review]
Bug 10745 - More fun on translation bug with XSLT subfieldSelect parameters

As in Bug 6278, this patch replace ">at<" with ">a_t<"
so not to mislead translators. Found more cases that
initial description.

To test:

1) Check that problem exists and only on xslt files,
using your preferred language

egrep -B10 "^msgid \"at\"" misc/translator/po/xx-YY-i-staff-t*

2) Apply the patch

3) Update translation file
(cd misc/translator; perl translate update xx-YY)

4) Verify the problem is gone, repeat 1

5) If you like verify new entries in PO file

egrep -B15 "^msgid \"a_t\"" misc/translator/po/xx-YY-i-staff-t*

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Tested this with field 780 and running a Dutch translation.

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Comment 6 Galen Charlton 2013-08-23 16:16:25 UTC
Pushed to master.  Thanks, Bernardo!
Comment 7 Tomás Cohen Arazi 2013-08-23 18:49:17 UTC
This patch has been pushed to 3.12.x, will be in 3.12.4.

Thanks Bernardo!
Comment 8 Bernardo Gonzalez Kriegel 2013-09-14 19:10:51 UTC
Pushed to 3.10.x, will be in 3.10.11