Bug 10778 - Store more information in statistics table
Summary: Store more information in statistics table
Status: RESOLVED DUPLICATE of bug 7021
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-22 10:14 UTC by mathieu saby
Modified: 2013-09-01 21:52 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mathieu saby 2013-08-22 10:14:38 UTC
Curently, statistic table contains some information about the item and the borrower (http://schema.koha-community.org/tables/statistics.html):
For the item : 
- itemnumber
- itemtype
- ccode
For the borrower
- borrowernumber
- associatedborrower
- and maybe "usercode" (not documented in schemaspy, so I don't know what it means).

I think we should store more information for the borrower : if the borrower record is deleted, we will not be able to get the useful informations (categorycode...) with a JOIN.

I am not sure of Koha's behavior if the item or biblio is deleted : if the itemnumber and biblionumber is deleted from statistic table, we could also store more information (as homebranch, location, biblio.serial, biblioitems.itemtype)

For the borrowers, I think we need :
- categorycode
- branchcode
- sex
- sort1
- sort2
and optionally the ability to record 3 or 4 custom fields with a syspref (for example, to store the extended attributes).

Do you agree with that ?

M. Saby
Comment 1 mathieu saby 2013-09-01 21:52:45 UTC

*** This bug has been marked as a duplicate of bug 7021 ***