Bug 10790 - adding/editing item types screen mis aligned if noItemTypeImages not showing
Summary: adding/editing item types screen mis aligned if noItemTypeImages not showing
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bernardo Gonzalez Kriegel
QA Contact: Testopia
URL:
Keywords:
: 11424 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-27 18:48 UTC by Nicole C. Engard
Modified: 2015-06-04 23:30 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
add item type (74.39 KB, image/png)
2013-08-27 18:48 UTC, Nicole C. Engard
Details
Bug 10790 - adding/editing item types screen mis aligned if noItemTypeImages not showing (1.60 KB, patch)
2014-03-20 01:32 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
[SIGNED OFF] Bug 10790 - adding/editing item types screen mis aligned if noItemTypeImages not showing (1.66 KB, patch)
2014-03-20 12:27 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 10790 - adding/editing item types screen mis aligned if noItemTypeImages not showing (1.72 KB, patch)
2014-03-20 12:48 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2013-08-27 18:48:29 UTC
Created attachment 20661 [details]
add item type

See attached.  When you have  noItemTypeImages  set to "Don't show" everything goes wonky on the add item type screen.
Comment 1 Bernardo Gonzalez Kriegel 2014-03-20 01:32:09 UTC Comment hidden (obsolete)
Comment 2 Bernardo Gonzalez Kriegel 2014-03-20 01:45:16 UTC
*** Bug 11424 has been marked as a duplicate of this bug. ***
Comment 3 M. Tompsett 2014-03-20 12:27:06 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2014-03-20 12:48:58 UTC
Created attachment 26483 [details] [review]
Bug 10790 - adding/editing item types screen mis aligned if noItemTypeImages not showing

This patch fixes the odd behavior when noItemTypesImages is set
to 'Don't show'. Just a misplaced </div>

To test:

1) Set syspref noItemTypeImages to 'Don't show'
2) Go to Admininstration > Item types
3) Edit some item type, you will view a display
similar to the attached image
4) Apply the patch
5) Reload the page, now the display is fixed
6) Change syspref to 'Show' to check that
the display is also good

Also fixed a missing '/' on a closing select

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 5 Galen Charlton 2014-04-07 15:52:04 UTC
Pushed to master.  Thanks, Bernardo!
Comment 6 Fridolin SOMERS 2014-06-19 15:43:33 UTC
Pushed to 3.14.x, will be in 3.14.08