Bug 10901 - Filters is needed on the add item page
Summary: Filters is needed on the add item page
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
: 11162 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-17 14:31 UTC by Jonathan Druart
Modified: 2014-07-18 15:44 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10901: Add datatables to the add item page (5.77 KB, patch)
2013-09-17 14:32 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10901: Add datatables to the add item page (5.82 KB, patch)
2013-09-19 08:00 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Screenshot showing withdrawn is not sortable (38.47 KB, image/png)
2013-09-22 09:13 UTC, Katrin Fischer
Details
Bug 10901: the withdrawn column should be sortable (1.03 KB, patch)
2013-09-23 07:59 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 10901: Add datatables to the add item page (6.03 KB, patch)
2013-09-24 06:43 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 10901: the withdrawn column should be sortable (1.09 KB, patch)
2013-09-24 06:43 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2013-09-17 14:31:31 UTC
For a biblio with a lot of items, it is not easy to find the one you want to edit.
Datatables could help using a filter box.
Comment 1 Jonathan Druart 2013-09-17 14:32:54 UTC Comment hidden (obsolete)
Comment 2 sandboxes@biblibre.com 2013-09-19 08:00:15 UTC
Patch tested with a sandbox, by Pierre Angot <tredok.pierre@gmail.com>
Comment 3 sandboxes@biblibre.com 2013-09-19 08:00:32 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2013-09-22 09:13:31 UTC
Created attachment 21309 [details]
Screenshot showing withdrawn is not sortable

Hi Jonathan,

I really like the idea of this :)

Just 2 things:

1) My withdrawn column was the only column not being sortable and a search for "withdrawn" brought up no results. Could you check what's going wrong there?

2) Having one general search box makes the search not very exact. For example if you wanted to check for "old" items by acquisitions date or last seen date the other date columns will interfere with the search. Maybe we could also add a search box for each column?

Failing for 1).
Comment 5 Jonathan Druart 2013-09-23 07:58:51 UTC
(In reply to Katrin Fischer from comment #4)
> 1) My withdrawn column was the only column not being sortable and a search
> for "withdrawn" brought up no results. Could you check what's going wrong
> there?

Yes, my bad, followup coming.

> 2) Having one general search box makes the search not very exact. For
> example if you wanted to check for "old" items by acquisitions date or last
> seen date the other date columns will interfere with the search. Maybe we
> could also add a search box for each column?

It is a more complex task. I didn't plan to add filter for each column.
Comment 6 Jonathan Druart 2013-09-23 07:59:06 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2013-09-23 08:04:14 UTC
Hi Jonathan, that's ok - I will add it to my wishlist :) Thx for the follow-up.
Comment 8 Katrin Fischer 2013-09-24 06:43:35 UTC
Created attachment 21392 [details] [review]
[PASSED QA] Bug 10901: Add datatables to the add item page

For a biblio with a lot of items, it is not easy to find the one you
want to edit.

Test plan:
Try to edit/delete item from the add item page.
Verify there is no regression on this page.

Signed-off-by: Pierre Angot <tredok.pierre@gmail.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script.
Adding, editing and deleting items still works.
Search provides useful help for locating the correct items.
Comment 9 Katrin Fischer 2013-09-24 06:43:46 UTC
Created attachment 21393 [details] [review]
[PASSED QA] Bug 10901: the withdrawn column should be sortable

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 10 Galen Charlton 2013-09-27 17:02:55 UTC
Pushed to master.  Thanks, Jonathan!

Since the two initial columns for the record actions have been collapsed into one, additional visual tweaking might be a good idea.
Comment 11 Owen Leonard 2014-07-18 15:44:34 UTC
*** Bug 11162 has been marked as a duplicate of this bug. ***