Bug 10915 - about->timeline broken on upgraded Koha
Summary: about->timeline broken on upgraded Koha
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: About (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Mason James
QA Contact: Marcel de Rooy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-19 12:18 UTC by Mason James
Modified: 2014-12-07 20:03 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10915 - about->timeline broken on upgraded Koha (993 bytes, patch)
2013-09-19 12:19 UTC, Mason James
Details | Diff | Splinter Review
Bug 10915 - about->timeline broken on upgraded Koha (1.02 KB, patch)
2013-09-19 12:23 UTC, Marcel de Rooy
Details | Diff | Splinter Review
before/after pic (179.79 KB, image/png)
2013-09-19 12:24 UTC, Mason James
Details
Bug 10915 - about->timeline broken on upgraded Koha (1.24 KB, patch)
2013-09-19 15:02 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 10915: (Possible) QA followup - warn if cannot read history.txt (3.24 KB, patch)
2013-09-19 15:42 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mason James 2013-09-19 12:18:01 UTC
the about->timeline display is broken on upgraded Kohas

this patch adds a default 'fall-back' doc path, if one has not been defined in the koha-conf.xml

this regression was caused by bug 8911
Comment 1 Mason James 2013-09-19 12:19:10 UTC Comment hidden (obsolete)
Comment 2 Marcel de Rooy 2013-09-19 12:23:57 UTC Comment hidden (obsolete)
Comment 3 Mason James 2013-09-19 12:24:49 UTC
Created attachment 21239 [details]
before/after pic
Comment 4 Marcel de Rooy 2013-09-19 12:26:15 UTC
QA Comment:
Small fix. Works.
Looks good to me. No complaints from qa tools.

Passed QA
Comment 5 Tomás Cohen Arazi 2013-09-19 15:02:00 UTC
Created attachment 21251 [details] [review]
Bug 10915 - about->timeline broken on upgraded Koha

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Fixes dev and standard installs without docdic tag in koha-conf.xml.
Doesn't break when docdir present either. Warning still present
on packages install that didn't add the docdir definition in koha-conf.xml
Comment 6 Tomás Cohen Arazi 2013-09-19 15:42:58 UTC
Created attachment 21253 [details] [review]
Bug 10915: (Possible) QA followup - warn if cannot read history.txt

This patch makes about.pl test if success opening history.txt, and
shows a convenient warning to the end user. No more warnings in the logs
(about.pl: readline() on closed filehandle $file at /usr/share/koha/intranet/cgi-bin/about.pl line 166)
and better problem solving information for the end user.

Regards
To+

Sponsored-by: Universidad Nacional de Cordoba
Comment 7 Galen Charlton 2013-09-20 17:29:01 UTC
Pushed to master.  Thanks, Mason!
Comment 8 Bernardo Gonzalez Kriegel 2013-10-13 22:48:09 UTC
Pushed to 3.10.x, will be in 3.10.12