Bug 10936 - Standardnumber doubled up in Advanced search - more options
Summary: Standardnumber doubled up in Advanced search - more options
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Target Milestone: ---
Assignee: Jesse Maseto
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 11613 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-24 11:57 UTC by Katrin Fischer
Modified: 2015-06-04 23:30 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
This patch removes the dupilcate "Standard Number" option under the more options of the opac advanced search. (13.93 KB, patch)
2014-03-12 10:04 UTC, Jesse Maseto
Details | Diff | Splinter Review
Patch updated. (2.10 KB, patch)
2014-03-12 12:00 UTC, Jesse Maseto
Details | Diff | Splinter Review
Patch updated. (2.19 KB, patch)
2014-03-12 13:01 UTC, Alex Sassmannshausen
Details | Diff | Splinter Review
Bug 10936 - Standardnumber doubled up in Advanced search - more options (2.48 KB, patch)
2014-03-13 21:21 UTC, Jesse Maseto
Details | Diff | Splinter Review
Bug 10936 (1.41 KB, patch)
2014-03-28 14:51 UTC, Jesse Maseto
Details | Diff | Splinter Review
[SIGNED OFF] Bug 10936 - 'Standard number' doubled up in Advanced search (1.87 KB, patch)
2014-03-31 05:16 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 10936 - Follow-up for Prog theme - Standardnumber doubled up in Advanced search - more options (1.34 KB, patch)
2014-04-16 12:34 UTC, Marc Véron
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10936 - Follow-up for Prog theme - Standardnumber doubled up in Advanced search - more options (1.48 KB, patch)
2014-04-28 19:44 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
[PASSED QA] Bug 10936 - 'Standard number' doubled up in Advanced search (1.93 KB, patch)
2014-05-15 21:23 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 10936 - Follow-up for Prog theme - Standardnumber doubled up in Advanced search - more options (1.54 KB, patch)
2014-05-15 21:23 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-09-24 11:57:36 UTC
Standard number is listed twice in advanced search, when more options are activated.
Comment 1 Stefano Bargioni 2013-12-17 16:41:39 UTC
If I'm not wrong, line 120 of en/modules/opac-advsearch.tt must be soppressed.
Comment 2 Jesse Maseto 2014-03-12 10:04:01 UTC Comment hidden (obsolete)
Comment 3 Jesse Maseto 2014-03-12 10:08:59 UTC
To test:

From the OPAC click on the "advanced search" option.
Then on the advanced search page click on "more options"
you will the see that "Standard number" is on the list twice.

Apply Patch.

Re-test and now only one option.
Comment 4 Alex Sassmannshausen 2014-03-12 11:44:19 UTC
Hi Jesse,

As agreed, I'm failing QA as the patch seems to add a number of new files:
- showdiffmarc.pl
- showdiffmarc.tt

(these files also currently use tab instead of space as indentation).

Let me know if I misunderstood.

Best wishes,

Alex
Comment 5 Jesse Maseto 2014-03-12 12:00:48 UTC Comment hidden (obsolete)
Comment 6 Alex Sassmannshausen 2014-03-12 13:01:07 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2014-03-13 08:40:20 UTC
*** Bug 11613 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Druart 2014-03-13 14:25:55 UTC
Please provide a correct commit message and a test plan.
Marked as Failed QA.
Comment 9 Jesse Maseto 2014-03-13 21:21:37 UTC Comment hidden (obsolete)
Comment 10 Katrin Fischer 2014-03-16 20:25:51 UTC
Comment on attachment 26322 [details] [review]
Bug 10936 - Standardnumber doubled up in Advanced search - more options

Review of attachment 26322 [details] [review]:
-----------------------------------------------------------------

::: koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-advsearch.tt
@@ +84,2 @@
>                                              [% END %]
>                                              <option value="sn">Standard number</option>

I am sorry, but this won't work quite right. Let me try to explain:

[% IF ( numbersphr) %]

refers to the system preference OPACNumbersPreferPhrase. It switches the index, one time it's sn,phr and the other time it's sn. 

If you apply the current patch and set OPACNumbersPreferPhrase to 'use', the index will still show up twice, because the IF is true and there is another 

<option value="sn">Standard number</option> 

below the former IF-ELSE construct.

If you delete this <option> instead, and keep the IF-ELSE as before, it should work alright.

Hope that did make some kind of sense :)
Comment 11 Jesse Maseto 2014-03-28 14:51:05 UTC Comment hidden (obsolete)
Comment 12 M. Tompsett 2014-03-31 04:42:11 UTC
I decided to attempt a grep:
$ grep -l "Standard number" `find . -name "*.tt"`
./koha-tmpl/intranet-tmpl/prog/en/modules/labels/search.tt
./koha-tmpl/opac-tmpl/prog/en/modules/opac-advsearch.tt
./koha-tmpl/opac-tmpl/prog/en/modules/opac-suggestions.tt
./koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-advsearch.tt
./koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-suggestions.tt

This problem exists in:
./koha-tmpl/opac-tmpl/prog/en/modules/opac-advsearch.tt
./koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-advsearch.tt

Please attach a fix for prog as well. This will allow for back ports to previous versions.

I changed this to a minor bug, not an enhancement. Please check the bug level in the future. Enhancement is the current default (BAD!!!!!).
Comment 13 M. Tompsett 2014-03-31 05:16:52 UTC Comment hidden (obsolete)
Comment 14 M. Tompsett 2014-03-31 05:18:04 UTC
I have left this as 'Needs Signoff', since I'm waiting for a prog theme patch.
Comment 15 Marc Véron 2014-04-16 12:34:57 UTC Comment hidden (obsolete)
Comment 16 Bernardo Gonzalez Kriegel 2014-04-28 19:44:04 UTC Comment hidden (obsolete)
Comment 17 Katrin Fischer 2014-05-15 21:23:22 UTC
Created attachment 28284 [details] [review]
[PASSED QA] Bug 10936 - 'Standard number' doubled up in Advanced search

This patch removes the dupilcate 'Standard number' option
under the more options of the opac advanced search correctly
following updates from Katrin.

TEST PLAN
---------
1) Set opacthemes system preference to bootstrap
2) In OPAC, click 'Advanced search'
3) Click 'More options'
4) Check the Keywords dropdown for duplicate 'Standard number'
5) Apply patch
6) Refresh page, and make sure 'More options' is clicked still
7) Check the Keywords dropdown for duplicate 'Standard number'
   -- it's not this time.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 18 Katrin Fischer 2014-05-15 21:23:59 UTC
Created attachment 28285 [details] [review]
[PASSED QA] Bug 10936 - Follow-up for Prog theme - Standardnumber doubled up in Advanced search - more options

TEST PLAN
---------
1) Set opacthemes system preference to prog
2) In OPAC, click 'Advanced search'
3) Click 'More options'
4) Check the Keywords dropdown for duplicate 'Standard number'
5) Apply patch
6) Refresh page, and make sure 'More options' is clicked still
7) Check the Keywords dropdown for duplicate 'Standard number'
   -- it's not this time

Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com>
Work as described on prog theme, no more duplicate.
No koha-qa errors

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 19 Galen Charlton 2014-05-22 21:47:42 UTC
Pushed to master and 3.16.x.  Thanks, Jesse and Marc!