Bug 10949 - hold request not retrieved when printing hold slip
Summary: hold request not retrieved when printing hold slip
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 9394
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 16:06 UTC by Galen Charlton
Modified: 2014-05-26 21:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
bug 10949: restore ability to successfully print hold slips (2.19 KB, patch)
2013-09-25 16:20 UTC, Galen Charlton
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10949: restore ability to successfully print hold slips (2.29 KB, patch)
2013-09-25 16:23 UTC, Owen Leonard
Details | Diff | Splinter Review
[PASSED QA] Bug 10949: restore ability to successfully print hold slips (2.62 KB, patch)
2013-09-27 21:34 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Galen Charlton 2013-09-25 16:06:25 UTC
When one checks in an item and uses the 'print and confirm' button to print a hold slip, the text printed out is only "reserve not found", with no information about the hold.

This appears to be a regression caused by the patch for bug 9394.
Comment 1 Galen Charlton 2013-09-25 16:20:10 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2013-09-25 16:23:49 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2013-09-27 21:34:24 UTC
Created attachment 21530 [details] [review]
[PASSED QA] Bug 10949: restore ability to successfully print hold slips

This fixes a regression introduced by the patch for bug
9394 -- when printing a hold slip using the 'print and confirm'
button, the slip would contain only the text 'reserve not found',
not a full hold slip.

This patch also adds a regression test.

To test:

[1] Check in an item that would fill a hold.  Use the 'print
    and confirm button' to confirm the hold.
[2] The printout will only contain text to the effect of
    'reserve not found'.
[3] Apply the patch.
[4] Repeat step 1.  This time, a full hold slip should be printed.
[5] Verify that prove -v t/db_dependent/Reserves.t passes.

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Pass all tests, new and old, and QA script.
Verified wrong and corrected behaviour.

Note: Sometimes there will not be the message 'reserve not found'
showing up, but hold information for a different record. This happens
when there exists a reserve_id with the borrowernumber of the patron
in question in your database.
Comment 4 Galen Charlton 2013-10-02 14:39:07 UTC
Pushed to master.