Bug 10985 - Unimarc: Authority summary does not work as expected
Summary: Unimarc: Authority summary does not work as expected
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Julian Maurice
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-02 12:20 UTC by Jonathan Druart
Modified: 2015-12-03 22:03 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this: 2013-10-28 00:00:00
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 10985: [UNIMARC] Fix authority summary (3.73 KB, patch)
2013-10-02 12:22 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10985: [UNIMARC] Fix authority summary (9.71 KB, patch)
2015-03-11 15:16 UTC, Julian Maurice
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10985: [UNIMARC] Fix authority summary (9.87 KB, patch)
2015-04-09 07:28 UTC, Frédéric Demians
Details | Diff | Splinter Review
[PASSED QA] Bug 10985: [UNIMARC] Fix authority summary (9.92 KB, patch)
2015-04-21 21:30 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2013-10-02 12:20:14 UTC
Example:
The following authority:

000 - Record Label
  @ 00190 a2200097 4500
001 - Record Identifier
  @ 55347
005 - Version Identifier
  @ 20131002124236.0
009 - ppn
  @ my_ppn
200 ## - Heading - Personal Name
  a Entry Element Personal name
  b Part of Name Other t G.

And the following summary:
  NP : [200a][, 200b][ 200d][-- 152b --][ ; 200c][ (200f)] [001*] [ppn: 009*]

We got:
 NP : 23849 ppn: -- NP : ppn: my_ppn -- NP : -- NP -- ppn: -- NP : Personal name, D. ppn: :
Comment 1 Jonathan Druart 2013-10-02 12:22:16 UTC Comment hidden (obsolete)
Comment 2 I'm just a bot 2013-10-03 06:59:41 UTC
Patch applied cleanly, go forth and signoff
Comment 3 I'm just a bot 2013-10-28 06:17:07 UTC
Patch applied cleanly, go forth and signoff
Comment 4 mathieu saby 2013-11-29 19:38:05 UTC
I put 
[200a][, 200b][ 200d][-- 152b --][ ; 200c][ (200f)] [001*] [ppn: 009*]
in Authority types for "NP"

without your patch, a search on authorities NP gives :
 1483 -- Aimée, Anouk -- -- NP -- : 
 1153 -- -- NP -- -- Aitchison, Jean (1925-....) : 
 1392 -- -- NP -- -- Alcalá-Zamora y Torres, Niceto (1877-1949) : 
 1579 -- Abraham, Daniel -- -- NP -- : 
 1011 -- -- NP -- -- 余, 华 (1960-....) -- Yu, Hua (1960-....) : 

So, it is broken.

with your patch, it gives:
 Aimée, Anouk-- NP -- 1483 : 
 Aitchison, Jean-- NP -- (1925-....) 1153 ppn: 031562558: 
 Alcalá-Zamora y Torres, Niceto-- NP -- (1877-1949) 1392 ppn: 031603718: 
 Abraham, Daniel-- NP -- 1579 : 
余, 华-- NP -- (1960-....) 1011 ppn: 033893438:
余 华 1960-.... Yu Hua 1960-....

So, it works ;-)

But I have a question for the last case. It is a record with two 200 fields, in chinese and in french. Is it normal to only have the chinese name on the first line (the line defined by "[200a][, 200b][ 200d][-- 152b --][ ; 200c][ (200f)] [001*] [ppn: 009*]") ?
If it is normal, I will sign off.

Mathieu
Comment 5 Jonathan Druart 2013-12-04 13:26:59 UTC
(In reply to mathieu saby from comment #4)
> But I have a question for the last case. It is a record with two 200 fields,
> in chinese and in french. Is it normal to only have the chinese name on the
> first line (the line defined by "[200a][, 200b][ 200d][-- 152b --][ ; 200c][
> (200f)] [001*] [ppn: 009*]") ?

Yes, this patch only processes the first field.
Comment 6 Julian Maurice 2015-03-11 15:16:25 UTC Comment hidden (obsolete)
Comment 7 Julian Maurice 2015-03-11 15:17:11 UTC
Patch rebased, test plan improved, and additional fix added
Comment 8 Frédéric Demians 2015-04-09 07:28:59 UTC Comment hidden (obsolete)
Comment 9 Katrin Fischer 2015-04-21 21:30:36 UTC
Created attachment 38293 [details] [review]
[PASSED QA] Bug 10985: [UNIMARC] Fix authority summary

The problem is the template in authority type summary is not respected
at all. It is only read to see which fields and subfields should appear
in the summary.
This patch fixes that.
It also fixes a bug in auth_finder.pl plugin when summary contains
fields other than 2XX.

Test plan:
0/ You must use a UNIMARC setup for those tests
1/ edit an authority type summary with:
     NP : [200a][, 200b][ 200d][-- 152b --][ ; 200c][ (200f)] [001*] [ppn: 009*]
2/ create a new authority with previous fields (it is possible some
   fields don't exist).
3/ search this authority and verify the summary is someting like:
     NP : Name, D.-- NP -- 23849 ppn: my_ppn
4/ Verify some summary for existing authorities and check they are
   correct.
5/ Edit a biblio record and use the plugin auth_finder.pl (for example
   in a 7XX field)
6/ Do a search and verify the summary is correct
7/ Click on 'choose' or one of the numbered links ('1', '2', ... ; you
should have multiple 2XX fields for the numbered links to show up)
8/ Verify that the biblio field is correctly filled.

/!\ For the ppn, it should be defined in the zebra indexes.

In MARC21 and NORMARC setups, this patch should change nothing, please
verify that too (you can check that the auth_finder.pl plugin is still
working and the auth type summary is correctly displayed in authorities
search and auth_finder.pl plugin).

Signed-off-by: Frederic Demians <f.demians@tamil.fr>

It works as described, both in authority search result page, and in authority
data entry plugin.

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Tomás Cohen Arazi 2015-04-22 16:28:34 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 11 Chris Cormack 2015-05-01 08:08:36 UTC
Pushed to 3.18.x will be in 3.18.7