Bug 11146 - Show a go back link on no permission page
Summary: Show a go back link on no permission page
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Authentication (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Fridolin SOMERS
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-28 12:45 UTC by Fridolin SOMERS
Modified: 2015-06-04 23:23 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11146 - Show a go back link on no permission page (2.82 KB, patch)
2013-10-28 12:57 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 11146 - Show a go back link on no permission page (2.91 KB, patch)
2013-11-20 02:10 UTC, Garming Sam
Details | Diff | Splinter Review
Bug 11146 - Show a go back link on no permission page (2.95 KB, patch)
2013-11-22 17:02 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2013-10-28 12:45:31 UTC
When a user has not the permission for a page or module, the authentication page is displayed with message : "Error: You do not have permission to access this page.".
Most librarians uses the "previous page" button of there browser to come back on the page they where before trying to get to this non-permitted page.

I propose to add a link to help comming back.
Comment 1 Fridolin SOMERS 2013-10-28 12:57:09 UTC Comment hidden (obsolete)
Comment 2 Fridolin SOMERS 2013-10-28 13:02:45 UTC
This is a demand for librarians not really used to internet browsers.
yes, it exists.
Comment 3 Garming Sam 2013-11-20 02:10:35 UTC Comment hidden (obsolete)
Comment 4 Liz Rea 2013-11-20 03:18:10 UTC
Quick note on this - the functionality is only available in the Prog theme - it will need to be added to the new default bootstrap theming.

Cheers,
Liz
Comment 5 Liz Rea 2013-11-20 07:33:35 UTC
See this is what happens when I have too many bug windows open. 

*sighs*
Comment 6 Kyle M Hall 2013-11-22 17:02:00 UTC
Created attachment 23094 [details] [review]
Bug 11146 - Show a go back link on no permission page

When a user has not the permission for a page or module, the authentication page is displayed with message : "Error: You do not have permission to access this page.".
Most librarians uses the "previous page" button of there browser to come back on the page they where before trying to get to this non-permitted page.

This patch adds a button to help comming back to previous page.
Also moves the link "Click to log out" as a button.

Test plan :
- Define a user with staff permissions but no permission on tools module
- Login with this user
=> You get to intranet home page
- Edit URL to go to tools module : cgi-bin/koha/tools/tools-home.pl
=> You get a page with a red error message and 2 buttons "Previous page" and "Log out"
- Click on "Previous page"
=> Go get to intranet home page
- Edit URL to go to tools module : cgi-bin/koha/tools/tools-home.pl
- Click on "Log out" button
=> You are logged-out and get to authentication page : cgi-bin/koha/mainpage.pl?logout.x=1

Signed-off-by: Garming Sam <garming@catalyst.net.nz>

Works as intended.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 7 Galen Charlton 2013-11-23 19:44:07 UTC
Pushed to master.  Thanks, Fridolin!
Comment 8 Fridolin SOMERS 2013-12-13 08:44:52 UTC
This patch has been pushed to 3.14.x, will be in 3.14.1
Comment 9 Tomás Cohen Arazi 2013-12-16 13:42:37 UTC
This patch has been pushed to 3.12.x, will be in 3.12.8.

Thanks Fridolin!