Bug 11264 - Add German seasons to serials
Summary: Add German seasons to serials
Status: RESOLVED DUPLICATE of bug 11262
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: 3.14
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Katrin Fischer
QA Contact: Jonathan Druart
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-17 23:43 UTC by Katrin Fischer
Modified: 2013-11-19 13:29 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11264: Add German seasons to serials (1.37 KB, patch)
2013-11-17 23:49 UTC, Katrin Fischer
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 11264: Add German seasons to serials (1.82 KB, patch)
2013-11-18 22:03 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 11264: Add German seasons to serials (1.87 KB, patch)
2013-11-19 09:08 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-11-17 23:43:30 UTC
Currently the seasons are hardcoded in Serials.pm.

i will add the German season names, so seasonal patterns can be used, until bug 11262 is fixed.
Comment 1 Katrin Fischer 2013-11-17 23:49:50 UTC Comment hidden (obsolete)
Comment 2 Bernardo Gonzalez Kriegel 2013-11-18 22:03:18 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2013-11-19 09:08:19 UTC
I will try to see with Julian if it is possible to find a normal way to translate these strings. While waiting for a patch, this one can be go into the 3.14 branch.

Marked as Passed QA
Comment 4 Jonathan Druart 2013-11-19 09:08:38 UTC
Created attachment 23022 [details] [review]
Bug 11264: Add German seasons to serials

This patch adds the German season names to the serials module.

Requirements: You must have a German locale de_* on your system.

To test:
- Add a new subscription in the serials module
- Create a subscription for 1/3 months, seasonal
- Begins with and inner counter should both be 0
- Year can be 2013 and second row empty
- Pick de* as a locale[1]
- Test the prediction pattern - it should tell you German seasons now
- Save the subscription - make sure the issues are crated with German
  seasons as well

[1] It seems you have to pick it explicitly - the fallback to the
    system locale noted on the field didn't work for me.

Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com>

Work as described. No koha-qa errors.

Installed de_DE.UTF-8 and fr_FR.UTF-8 locales
Add new suscription, picked locale manually (de_DE in this case)
Prediction pattern shows correct labels (to selected locale)
Received issues generated with correct numbering

Really don't know at this moment how this could be added to
general translation. I'm tempted to add a followup for Spanish

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 5 Jonathan Druart 2013-11-19 13:29:18 UTC
Will be fix by bug 11262

*** This bug has been marked as a duplicate of bug 11262 ***