Bug 11303 - Add to Cart doesn't work in pro > MARC biblio view
Summary: Add to Cart doesn't work in pro > MARC biblio view
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on: 9780
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-26 09:41 UTC by Frédéric Demians
Modified: 2015-06-04 23:23 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Demians 2013-11-26 09:41:19 UTC
To reproduce this bug:

- Do a search in pro interface
- On the result page, click on a biblio record title
- On detail page, click on MARC tab if not already selected
- Click on Add to > Cart

Nothing happens. This is due to the fact that cat-toolbar.inc JavaScript
is broken when called from MARCdetail.tt rather than detail.tt. Bug 9780
introduced two new variables countorder, and countdeletedorders, which
are populated by detail.pl but not by MARCdetail.pl.
Comment 1 Frédéric Demians 2013-11-26 15:40:08 UTC
Same issue on ISBD tab: ISBDdetail.pl.
Comment 2 Fridolin Somers 2014-05-19 12:39:25 UTC
Corrected by Bug 11829 no ?
Comment 3 Katrin Fischer 2014-11-10 22:44:36 UTC
Works on current master.