Bug 11337 - calls to GetSubscriptions can be replaced by Searchsubscriptions
Summary: calls to GetSubscriptions can be replaced by Searchsubscriptions
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-04 14:23 UTC by Jonathan Druart
Modified: 2015-12-03 22:11 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 11337: Remove the C4::Serials::GetSubscriptions routine (9.69 KB, patch)
2013-12-04 14:30 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 11337: Remove the C4::Serials::GetSubscriptions routine (9.71 KB, patch)
2015-01-23 00:54 UTC, Aleisha Amohia
Details | Diff | Splinter Review
[PASSED QA] Bug 11337: Remove the C4::Serials::GetSubscriptions routine (9.78 KB, patch)
2015-01-23 16:58 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11337: Remove the C4::Serials::GetSubscriptions routine (9.95 KB, patch)
2015-04-13 13:27 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2013-12-04 14:23:44 UTC
These 2 routines do the same think. They can be merged.
Comment 1 Jonathan Druart 2013-12-04 14:30:20 UTC Comment hidden (obsolete)
Comment 2 Aleisha Amohia 2015-01-23 00:54:48 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2015-01-23 16:58:11 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2015-04-13 13:27:43 UTC
Created attachment 37739 [details] [review]
Bug 11337: Remove the C4::Serials::GetSubscriptions routine

Since SearchSubscriptions is the way to search subscriptions, each call
to GetSubscriptions could be replaced by a call to SearchSubscriptions.

Test plan:
Verify following pages display the same thing as before this patch:
- catalogue/detail.pl
- opac/opac-ISBDdetail.pl
- opac/opac-detail.pl

Verify the following page returns correct results:
- serials/checkexpiration.pl

Verify the Serials UT file still passes:
- prove t/db_dependent/Serials.t

Note: The title filter on checkexpiration now only searches on the title
DB field. I don't think it is a regression, it should be the way to use
this field. Maybe should we add new search fields on this form.
Bug 5337 reintroduces a bug fixed by bug 5864, this patch restore the
right way to search subscription (based on biblionumber).

Signed-off-by: Aleisha <aleishaamohia@hotmail.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 5 Jonathan Druart 2015-04-13 13:28:13 UTC
The last patch fixes a trivial conflict on the test file.
Comment 6 Tomás Cohen Arazi 2015-04-13 13:40:05 UTC
Patch pushed to master.

Thanks Jonathan!