Bug 11514 - "Uncertain" no longer display in acq
Summary: "Uncertain" no longer display in acq
Status: Pushed to master
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 13323
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-10 09:40 UTC by paxed
Modified: 2019-11-06 17:10 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.11.00


Attachments
Bug 11514: Untranslatable "Uncertain" text in acq (5.55 KB, patch)
2019-07-08 15:29 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 11514: Untranslatable "Uncertain" text in acq (5.62 KB, patch)
2019-09-30 14:45 UTC, Christophe Croullebois
Details | Diff | Splinter Review
Bug 11514: Untranslatable "Uncertain" text in acq (5.83 KB, patch)
2019-11-05 09:49 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description paxed 2014-01-10 09:40:55 UTC
Hard-coded, untranslatable text in acquisitions:

acqui/basket.pl:        $line{rrpgste} .= ' (Uncertain)';
acqui/invoice.pl:        $line{rrp} .= ' (Uncertain)';
Comment 1 paxed 2014-04-23 07:30:54 UTC
Also hardcoded "Deleted bibliographic notice, can't find title." in acqui/basket.pl
Comment 2 Jonathan Druart 2015-04-24 09:20:54 UTC
I will try to provide a patch when bug 13323 will be pushed.
Comment 3 Marc Véron 2017-04-03 06:27:12 UTC
Still valid?
Comment 4 Katrin Fischer 2017-04-03 06:30:35 UTC
Hm, needs testing?
Comment 5 Jonathan Druart 2017-04-03 12:47:19 UTC
acqui/basket.pl:        $line{rrp_tax_excluded} .= ' (Uncertain)';
acqui/invoice.pl:        $line{rrp} .= ' (Uncertain)';
Comment 6 Katrin Fischer 2018-05-16 01:57:43 UTC
Still an issue.
Comment 7 Owen Leonard 2019-07-08 15:29:57 UTC Comment hidden (obsolete)
Comment 8 Christophe Croullebois 2019-09-30 14:45:09 UTC Comment hidden (obsolete)
Comment 9 Nick Clemens 2019-10-01 06:56:36 UTC
I can't make the 'Uncertain' text appear before these patches, can you explain a little more?
Comment 10 Katrin Fischer 2019-10-07 22:10:19 UTC
While I think the patch doesn't break anything, it doesn't make sense to me.

1) Uncertain doesn't show on the basket page now, but I am almost certain that it used to. So the patch might be seen as a bug fix.

2) For invoices: A basket that has an uncertain price in it cannot be closed. Order from an unclosed basket cannot be added to invoices - so I am not sure how to test the second change.

Back to Christophe for help with the test plan - or maybe someone else can help?
Comment 11 Jonathan Druart 2019-10-15 08:45:37 UTC
I can confirm that:

1) It's a bug fix for the existing behavior: "(Uncertain)" is not longer displayed, because of the use of the Price plugin.

2) We cannot test the second part of the patch. Even if it cannot hurt it may make more sense to remove the code in the controller and don't touch the template file.
Comment 12 Katrin Fischer 2019-10-15 17:45:48 UTC
(In reply to Jonathan Druart from comment #11)
> I can confirm that:
> 
> 1) It's a bug fix for the existing behavior: "(Uncertain)" is not longer
> displayed, because of the use of the Price plugin.
> 
> 2) We cannot test the second part of the patch. Even if it cannot hurt it
> may make more sense to remove the code in the controller and don't touch the
> template file.

Thx, Jonathan!
Comment 13 Jonathan Druart 2019-11-04 10:50:08 UTC
Owen, you closed this bug but I think it is still useful. Even if it needs a small adjustment.

See comment 11

> 1) It's a bug fix for the existing behavior: "(Uncertain)" is not longer displayed, because of the use of the Price plugin.
Comment 14 Owen Leonard 2019-11-04 12:32:26 UTC
(In reply to Jonathan Druart from comment #13)
> Owen, you closed this bug but I think it is still useful. Even if it needs a
> small adjustment.

The bug refers to a translation issue and the translation issue is now invalid. If someone else want to continue to work on it I suggest at least renaming the report.
Comment 15 Jonathan Druart 2019-11-05 09:49:14 UTC
Created attachment 95043 [details] [review]
Bug 11514: Untranslatable "Uncertain" text in acq

This patch modifies two pages so that the "Uncertain price" information
is shown by the template rather than the Perl script, making the text
translatable.

To test, apply the patch and go to Acquisitions.

 - Locate or create an order in a basket which has an uncertain price.
 - When viewing the contents of that basket the order which was marked
   as having an uncertain price should be labeled "Uncertain."
 - The same should be true for the invoice page. If you don't have an
   existing invoice with an "uncertain" order,
   - Go to "Receive shipments" for the vendor your "uncertain" order is
     with.
   - Create a new invoice.
   - Receive one or more orders which has an uncertain price.
   - Press the "finish receiving" button.
   - In the "Invoice details" section of the invoice page you should
     see the "Uncertain" label on the correct order.

Signed-off-by: Christophe Croullebois <christophe.croullebois@biblibre.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
For the invoice view: close, receive, reopen, mark prices uncertain, go
to the invoice page (not sure it's expected however)
Comment 16 Martin Renvoize 2019-11-06 17:10:07 UTC
Nice work!

Pushed to master for 19.11.00