Bug 11564 - Sorting any search on a date column fails!
Summary: Sorting any search on a date column fails!
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P3 major (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-15 18:07 UTC by Kyle M Hall
Modified: 2017-06-14 22:08 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-01-15 18:07:42 UTC
It appears that any attempt to sort a search on a date column fails. The two date columns that can be searched on are publication date and acquisition date.

Video: http://screencast.com/t/yaRfaqA7mW2r

I've also reproduced this on master.
Comment 1 Katrin Fischer 2014-01-20 06:56:50 UTC
Hi Kyle, might be good to check - does it behave the same with and without QueryParser?
Comment 2 Marc Véron 2014-08-10 19:55:11 UTC
I could reproduce the problem in advanced (advanced search ind staff client) with 3.16.02 and with current master.
The Bug occurs not only with sorting after dates. I had it. e.g. after serching for publication year 2013 and sorting after Author.

Set to P3 major because parts of search functionality is broken.

During the tests, I had following URLs:

1)
Staff client, advanced search, search for publication year 2013
/cgi-bin/koha/catalogue/search.pl?idx=yr&q=2013&idx=kw&idx=kw&sort_by=relevance

2)
Sort result by publication year results in following URL
/cgi-bin/koha/catalogue/search.pl?idx=yr%252Cst-numeric&q=2013&sort_by=pubdate_dsc
Result: Empty

3)
I changed the URL to:
/cgi-bin/koha/catalogue/search.pl?idx=yr&idx=st-numeric&q=2013&sort_by=pubdate_dsc
Result: List displays as expected.

The part %252C seems to be the result of some double-encoding, could be 
%252c = %2C = a comma (,)  (following http://stackoverflow.com/questions/8348197 )

Replacing %252c with a comma resulted in an empty list.
I then repaced it with &idx= and had the expected result.
Comment 3 Jonathan Druart 2016-11-22 09:45:25 UTC
This seems to be fixed.