Bug 11571 - Bug 7934 introduces a regression in the translate script
Summary: Bug 7934 introduces a regression in the translate script
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 7934
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-16 14:46 UTC by Jonathan Druart
Modified: 2015-06-04 23:23 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11571: FIX regression introduced by bug 7934 (2.13 KB, patch)
2014-01-16 14:53 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 11571: FIX regression introduced by bug 7934 (2.13 KB, patch)
2014-01-17 08:13 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED OFF] Bug 11571 - FIX regression introduced by bug 7934 (2.39 KB, patch)
2014-01-24 16:05 UTC, M. Tompsett
Details | Diff | Splinter Review
[PASSED QA] Bug 11571 - FIX regression introduced by bug 7934 (2.48 KB, patch)
2014-01-25 09:05 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2014-01-16 14:46:39 UTC
Bug 7934 breaks the -f option introduced by bug 9161.
Comment 1 Jonathan Druart 2014-01-16 14:53:00 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2014-01-17 08:13:20 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2014-01-17 08:14:05 UTC
Second patch replaces 'not' with 'now' in the commit message...
Comment 4 Jonathan Druart 2014-01-24 15:22:56 UTC
Since it is a regression, easier to test and makes me waste a lot of time (on testing translation), I consider this bug as major.
Comment 5 Jonathan Druart 2014-01-24 15:23:36 UTC
s/easier/easy
Comment 6 M. Tompsett 2014-01-24 16:05:29 UTC Comment hidden (obsolete)
Comment 7 Jonathan Druart 2014-01-24 16:32:10 UTC
> -- verify the output and the execution time is now corrected.
s/is/are
...
Comment 8 Katrin Fischer 2014-01-25 09:05:35 UTC
Created attachment 24729 [details] [review]
[PASSED QA] Bug 11571 - FIX regression introduced by bug 7934

Bug 7934 breaks the -f option introduced in bug 9161.

While the generation of the command tmpl_process3.pl, a space is
missing if the -x option is given.
The tmpl_process3.pl is called like:
/home/koha/src/misc/translator/tmpl_process3.pl -q update -i
/home/koha/src/koha-tmpl/intranet-tmpl/prog/en/ -s
/home/koha/src/misc/translator/po/fr-FR-i-staff-t-prog-v-3006000.po -r
-x 'help'-f pay.tt

Revised test plan:
1) cd ./misc/translator
2) put a warn at LangInstaller.pm line 375.
3) time ./translate update fr-FR -f pay.tt
-- note the execution time and the output. The options in the
    command contain "-x 'help'-f pay.tt"
    The -f param is not passed to the script.
    The execution time is strangely long.
5) git reset --hard origin/master
6) apply this patch
7) put a warn at LangInstaller.pm line 375.
8) time ./translate update fr-FR -f pay.tt
-- verify the output and the execution time is now corrected.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script.
Comment 9 Galen Charlton 2014-01-26 15:53:15 UTC
Pushed to master.  Thanks, Jonathan!
Comment 10 Fridolin SOMERS 2014-06-03 09:51:36 UTC
I've choosen to not backport Bug 7934 to 3.14.x so this this resolved. 
This is now in 3.16.x