Bug 11693 - Default emailing preferences not loaded for self registering patron
Summary: Default emailing preferences not loaded for self registering patron
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Marcel de Rooy
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 12796 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-05 18:57 UTC by JB
Modified: 2016-12-05 21:23 UTC (History)
11 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 11693: Default emailing preferences not loaded for self registering patron (2.72 KB, patch)
2015-07-05 11:31 UTC, Marcel de Rooy
Details | Diff | Splinter Review
[Signed-off] Bug 11693: Default emailing preferences not loaded for self registering patron (2.87 KB, patch)
2015-07-05 15:34 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 11693: Default emailing preferences not loaded for self registering patron (2.92 KB, patch)
2015-07-09 11:28 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description JB 2014-02-05 18:57:02 UTC
If a new patron uses the self registering option, their record is not created with the default emailing preferences, but is left blank.
Comment 1 Liz Rea 2014-02-13 03:56:11 UTC
Ew this is an annoying bug. 

However, it does illustrate something - perhaps we should allow self registering borrowers to set their own messaging preferences at registration time, rather than enforcing the default for that category.

What do you think?
Comment 2 JB 2014-03-29 16:23:15 UTC
We were really wanting to prevent them from changing the preferences because we don't print any paper reports for checkout etc. If we protect them from making changes as we would like to do, we are also unable to access this information to set their preferences because it does not even display in the patron record.

Therefore, we have to allow the patrons access to this information and then just manually change it ourselves anytime a patron self registers. I've set the emailing to come to me when anyone self registers so that I will find their record and update the preferences. Most patrons don't know much about the preferences and the difference between "email" and "digest".

I do understand this is just a minor problem as I can get around it.

I'm very thankful to those wonderful programmers who make all the updates and keep everything running smoothly!!

Thanks.
Comment 3 Katrin Fischer 2014-08-23 18:34:28 UTC
*** Bug 12796 has been marked as a duplicate of this bug. ***
Comment 4 Marcel de Rooy 2015-07-05 11:31:28 UTC Comment hidden (obsolete)
Comment 5 Marc Véron 2015-07-05 15:34:46 UTC Comment hidden (obsolete)
Comment 6 Jonathan Druart 2015-07-09 11:28:51 UTC
Created attachment 40877 [details] [review]
Bug 11693: Default emailing preferences not loaded for self registering patron

The call to AddMember_Opac does not take care of the messaging prefs
when enhanced messaging is enabled.
This patch adds the call to handle_form_action to do that.

Test plan:
Enable self registering patrons and enhanced messaging.
Check the (default) message prefs for the relevant patron category. At least
enable email for one notice.
Self-register a user with and without verification email enabled.
Check in both cases that the message prefs of the user conform to
those in the patron category. (So at least one enabled.)

Followed test plan, works as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 7 Tomás Cohen Arazi 2015-07-24 17:11:09 UTC
Patch pushed to master.

Thanks Marcel!
Comment 8 Chris Cormack 2015-08-09 21:33:52 UTC
Pushed to 3.20.x will be in 3.20.3
Comment 9 Liz Rea 2015-08-11 02:01:58 UTC
Pushed to 3.18.x, will be in 3.18.10.
Comment 10 Mason James 2015-08-28 05:45:32 UTC
Pushed to 3.16.x, will be in 3.16.14