Bug 11761 - Multiple notifications for borrowers if checked out from many branches during one day. (caused by overdue_notifications.pl)
Summary: Multiple notifications for borrowers if checked out from many branches during...
Status: RESOLVED MOVED
Alias: None
Product: Koha
Classification: Unclassified
Component: Notices (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-14 12:26 UTC by Olli-Antti Kivilahti
Modified: 2019-02-10 10:54 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olli-Antti Kivilahti 2014-02-14 12:26:20 UTC
When you have a Borrower A, who makes n Checkouts from Branches 1,2,3.

overdue_notifications.pl generates one message_queue-table -entry for each Branch containing all the Items n.
Thus the same Items' overdue notifications are generated for Branches 1,2,3, regardless of the checkout-events branch of origin.
The Borrower ends up receiving 3 overdue notifications each having the same Items.

This is a fringe case and it is hard to imagine someone checking out from more than one branch during the same day, and that such a hardcore library addict would forget to return his books.

Not expecting anyone to fix this but reporting it because identified it during testing.
Comment 1 Ray Delahunty 2017-01-17 09:22:21 UTC
We are a multi-college library with 6 libraries spread around central London. There is some course overlap and it is NOT unusual for users to visit more than one library in a day. Whether these users are hardcore library addicts is debatable. But we did send out three ODUE emails to one user the other day, each listing the same 9 items as overdue, one email from each of the three libraries this dedicated library user had visited and borrowed items from. Ideally, in multi-library Koha sites the digest emails would become a digest of digests.
Ray Delahunty
University of the Arts London
Comment 2 Katrin Fischer 2017-01-17 23:08:08 UTC
Hi Ray, I think what you describe might have been solved by 17470 - the item list now should only include items from the right branch.
Comment 3 Katrin Fischer 2019-02-10 10:54:49 UTC
I believe the original issue was fixed by bug 17470. There is also another bug for sending only one centralized message now:

Bug 17649 - Create only one message per borrower and overdue level

I am closing this as RESOLVED MOVED - please reopen if I am missing something.