Bug 11762 - Sequence of MARC21 245 subfields different on XSLT result list and detail page
Summary: Sequence of MARC21 245 subfields different on XSLT result list and detail page
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Bibliographic data support (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Alex Sassmannshausen
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 6502 12766 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-14 14:03 UTC by Katrin Fischer
Modified: 2015-06-04 23:30 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11762 - bootstrap: Re-order 245 $a $b $h in results. (5.85 KB, patch)
2014-03-13 15:02 UTC, Alex Sassmannshausen
Details | Diff | Splinter Review
Bug 11762 - intranet & prog: Re-order 245 $a $b $h in results. (10.70 KB, patch)
2014-03-13 15:04 UTC, Alex Sassmannshausen
Details | Diff | Splinter Review
Bug 11762 - intranet & prog: Re-order 245 $a $b $h in results. (10.70 KB, patch)
2014-03-13 16:10 UTC, Alex Sassmannshausen
Details | Diff | Splinter Review
Bug 11762 - bootstrap: Re-order 245 $a $b $h in results. (5.85 KB, patch)
2014-03-13 16:11 UTC, Alex Sassmannshausen
Details | Diff | Splinter Review
Bug 11762 - intranet & prog: Re-order 245 $a $b $h in results. (10.75 KB, patch)
2014-03-13 16:20 UTC, Jesse Weaver
Details | Diff | Splinter Review
Bug 11762 - bootstrap: Re-order 245 $a $b $h in results. (5.90 KB, patch)
2014-03-13 16:20 UTC, Jesse Weaver
Details | Diff | Splinter Review
[PASSED QA] Bug 11762 - intranet & prog: Re-order 245 $a $b $h in results. (10.96 KB, patch)
2014-03-14 11:26 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 11762 - bootstrap: Re-order 245 $a $b $h in results. (5.97 KB, patch)
2014-03-14 11:26 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2014-02-14 14:03:20 UTC
While the XSLT result list displays a b h, the detail page does better and displays a h b. 
This applies to both staff and OPAC MARC21 XSLT pages.
Comment 1 Alex Sassmannshausen 2014-03-13 14:37:26 UTC
Problem is caused by mismatching XSLT in:
+ MARC21
  - koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACMARCdetail.xsl
  - koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACResults.xsl
  - koha-tmpl/opac-tmpl/bootstrap/en/xslt/MARC21slim2OPACResults.xsl
  - koha-tmpl/opac-tmpl/bootstrap/en/xslt/MARC21slim2OPACResults.xsl
  - koha-tmpl/intranet-tmpl/prog/en/xslt/MARC21slim2intranetDetail.xsl
  - koha-tmpl/intranet-tmpl/prog/en/xslt/MARC21slim2intranetResults.xsl

+ NORMARC:
  - koha-tmpl/opac-tmpl/prog/en/xslt/NORMARCslim2OPACDetail.xsl
  - koha-tmpl/opac-tmpl/prog/en/xslt/NORMARCslim2OPACResults.xsl
  - koha-tmpl/opac-tmpl/bootstrap/en/xslt/NORMARCslim2OPACDetail.xsl
  - koha-tmpl/opac-tmpl/bootstrap/en/xslt/NORMARCslim2OPACResults.xsl
  - koha-tmpl/intranet-tmpl/prog/en/xslt/NORMARCslim2intranetDetail.xsl
  - koha-tmpl/intranet-tmpl/prog/en/xslt/NORMARCslim2intranetResults.xsl

I'm submitting patches to correct these mis-matches in favour of the display in Detail.xsl (a h b).

Best wishes,

Alex
Comment 2 Alex Sassmannshausen 2014-03-13 15:02:54 UTC Comment hidden (obsolete)
Comment 3 Alex Sassmannshausen 2014-03-13 15:04:15 UTC Comment hidden (obsolete)
Comment 4 Alex Sassmannshausen 2014-03-13 16:10:58 UTC Comment hidden (obsolete)
Comment 5 Alex Sassmannshausen 2014-03-13 16:11:18 UTC Comment hidden (obsolete)
Comment 6 Jesse Weaver 2014-03-13 16:20:54 UTC Comment hidden (obsolete)
Comment 7 Jesse Weaver 2014-03-13 16:20:58 UTC Comment hidden (obsolete)
Comment 8 M. Tompsett 2014-03-14 03:47:19 UTC
You forgot to mark as signed off, Jesse. :)
Comment 9 Katrin Fischer 2014-03-14 11:26:08 UTC
Created attachment 26340 [details] [review]
[PASSED QA] Bug 11762 - intranet & prog: Re-order 245 $a $b $h in results.

In the results view for OPAC and Intranet search results, titles are
currently displayed in 245 $a $b $h order. In detailed view the titles
are displayed in the better 245 $a $h $b order.

This patch corrects the behaviour for NORMARCS and MARC21: all now
display 245 $a $h $b.

To test:
- Find records containing 245 $a $b and $h fields.
- Compare the way they look in detail and results view in OPAC
  (non-bootstrap) and intranet (you should see a discrepancies).
- Apply the patch.
- Re-check detail and results view: all should now look the same in
  both OPAC (non-bootstrap) and intranet.

Signed-off-by: Jesse Weaver <pianohacker@gmail.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script, works as described.
Checked with Magnus Enger about the changes for the NORMARC
stylesheets and the changes are ok.
Comment 10 Katrin Fischer 2014-03-14 11:26:22 UTC
Created attachment 26341 [details] [review]
[PASSED QA] Bug 11762 - bootstrap: Re-order 245 $a $b $h in results.

In the results view for OPAC and Intranet search results, titles are
currently displayed in 245 $a $b $h order. In detailed view the titles
are displayed in the better 245 $a $h $b order.

This patch corrects the behaviour for NORMARCS and MARC21 in
BOOTSTRAP: all now display 245 $a $h $b.

To test:
- Find records containing 245 $a $b and $h fields.
- Compare the way they look in detail and results view on the OPAC
  (bootstrap).
- Apply the patch.
- Re-check detail and results view: all should now look the same
  on the OPAC (bootstrap).

Signed-off-by: Jesse Weaver <pianohacker@gmail.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 11 Galen Charlton 2014-03-14 15:20:59 UTC
Pushed to master.  This appears to the first patch of yours accepted into Koha master.  Congratulations, Alex!
Comment 12 Katrin Fischer 2014-03-15 08:30:54 UTC
*** Bug 6502 has been marked as a duplicate of this bug. ***
Comment 13 Fridolin SOMERS 2014-06-12 08:27:33 UTC
Pushed to 3.14.x, will be in 3.14.08
Comment 14 Kyle M Hall 2014-06-13 12:47:12 UTC
Pushed to 3.12.x, will be in 3.12.13
Comment 15 Katrin Fischer 2014-08-24 18:31:26 UTC
*** Bug 12766 has been marked as a duplicate of this bug. ***