Bug 11831 - ISBD and MARC view in Staff client (and Opac?) does not print
Summary: ISBD and MARC view in Staff client (and Opac?) does not print
Status: RESOLVED DUPLICATE of bug 11829
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff interface (show other bugs)
Version: master
Hardware: All All
: P3 normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-24 16:23 UTC by Marc Véron
Modified: 2014-02-24 16:29 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Véron 2014-02-24 16:23:11 UTC
See koha@lists.kapito.co.nz, 24.02.2014 15:37, Bhaskar Ghosh
"ISBD and MARC view page in Staff client and OPAC, print tab does not work in KOHA 3.14.xx."

I can reproduce this problem for versions 3.14.01 and current master with Firefox 27 and Chrome 33

- OPAC (bootstrap and prog theme) does print, but gives JavaScript warning in console

- Staff client does not print, same JavaScript warning in console

Warning in Firefox (Staff):
Empty string passed to getElementById() 
(...) intranet-tmpl/lib/jquery/jquery.js  Line: 2

Warning in Firefox (Opac):
Empty string passed to getElementById() 
Zeitstempel: 24.02.2014 17:16:31
(...) opac-tmpl/bootstrap/lib/jquery/jquery.js Line:2

In Chrome:
Error:
Uncaught SyntaxError: Unexpected token ; MARCdetail.pl:310

Warning:
event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

Marc Véron
Comment 1 Owen Leonard 2014-02-24 16:29:51 UTC

*** This bug has been marked as a duplicate of bug 11829 ***