Bug 11857 - Number of patrons on a patron list not accurate
Summary: Number of patrons on a patron list not accurate
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Fridolin SOMERS
QA Contact: Testopia
URL:
Keywords:
: 11950 (view as bug list)
Depends on: 10565
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-27 08:47 UTC by Marcel de Rooy
Modified: 2015-06-04 23:30 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11857 - Number of patrons on a patron list not accurate (2.04 KB, patch)
2014-06-05 15:31 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 11857 - Number of patrons on a patron list not accurate (2.15 KB, patch)
2014-06-09 03:20 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
[PASSED QA] Bug 11857 - Number of patrons on a patron list not accurate (2.29 KB, patch)
2014-06-09 10:21 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2014-02-27 08:47:41 UTC
I added one patron to a patron list.
On the Patron lists form it says that the list contains 3 patrons.
The table looked like this at that moment:
+-----------------------+----------------+----------------+
| patron_list_patron_id | patron_list_id | borrowernumber |
+-----------------------+----------------+----------------+
|                    19 |              3 |             23 |
+-----------------------+----------------+----------------+
Comment 1 Marcel de Rooy 2014-02-27 08:51:42 UTC
Just mentioning that when I saw Koha/List/Patron.pm for the first time, I really had no idea what it was. Too much abstraction perhaps :)

Since we already have lists (virtual shelves), I would have preferred a class like PatronList. Adding something different in the Koha/List folder would probably just add to the confusion.
Comment 2 Marcel de Rooy 2014-02-27 09:13:52 UTC
And even more confusing: pref AddPatronLists.. Has nothing to do with patron lists at all.
Comment 3 Fridolin SOMERS 2014-06-05 15:31:08 UTC Comment hidden (obsolete)
Comment 4 Fridolin SOMERS 2014-06-05 15:42:01 UTC
I'm not 100% sure how the patch works, I'm new to DBIx.
Comment 5 Bernardo Gonzalez Kriegel 2014-06-09 03:20:08 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2014-06-09 10:21:00 UTC
Created attachment 28728 [details] [review]
[PASSED QA] Bug 11857 - Number of patrons on a patron list not accurate

When creating a patron list with only 1 patron, the patron
lists page says that the list contains 3 patrons.
When creating a patron list with only 1 patron, it works fine.

This is caused by the fact that access on "patron_list_patrons"
Koha::Schema::Result::PatronList object returns an hash if one
result and an array if more results.
See similar problem at
http://permalink.gmane.org/gmane.comp.lang.perl.modules.template-toolkit/7250

This patch replaces by the call on resultset and then the use of
"count" method.

Test plan :
- Go to patron lists : /cgi-bin/koha/patron_lists/lists.pl
- Create a new patron list LIO
- Add one patron
- Create a new patron list LIM
- Add 2 patrons
- Go to patron lists : /cgi-bin/koha/patron_lists/lists.pl
=> Without this patch you see :
  Name  Patrons in list
  LIO   3
  LIM   2
=> With this patch you see :
  Name  Patrons in list
  LIO   1
  LIM   2

Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com>
Work as described, no koha-qa errors.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script. Confirmed the problem and that
the patch fixes it.
Comment 7 Tomás Cohen Arazi 2014-07-02 18:56:54 UTC
Patch pushed to master.

Thanks Fridolin!
Comment 8 Galen Charlton 2014-07-23 21:33:48 UTC
Pushed to 3.16.x for inclusion in 3.16.2.
Comment 9 Owen Leonard 2014-08-20 18:03:32 UTC
*** Bug 11950 has been marked as a duplicate of this bug. ***