Bug 11924 - warning about hold when item checked in at wrong library
Summary: warning about hold when item checked in at wrong library
Status: RESOLVED DUPLICATE of bug 13153
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-11 18:17 UTC by Nicole C. Engard
Modified: 2015-02-08 02:24 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2014-03-11 18:17:45 UTC
This was received via email:
-------------

I guess what I'm seeing as the problem is this:

1. PatronX places an item on hold for pickup at Library A.

2. Library B sends a copy of the item to Library A.

3. The item is checked in at Library A and Koha switches the status of the item to "Item is waiting for PatronX at Library A."

4. A staff member at Library A hands the item to PatronX and, for whatever reason, the item does not get checked out to PatronX.

5. PatronX uses the item and then returns it to Library C.

6. Staff at Library C checks in the item and Koha does nothing. When you look at the item record it says "Item is waiting for PatronX at Library A." Koha does not change the status of the item, it does not display a "Route to Library A" message, it does not change the holding location. Koha does nothing even though the item does not belong at Library C in any way shape or form.


Yes, there is a procedure problem here. At step 4 the staff member at Library A screwed up and let PatronX leave the library building with an item that had not been checked out.

What I'd like Koha to do is to give the staff at Library C some kind of alert when step 6 is reached so that staff at Library C know that the item is supposedly on hold at Library A. Since Koha doesn't do _anything_ at checkin, if this kind of mistake is made the error created by staff at Library A can be further complicated if staff at Library C are as inattentive as staff at Library A. 

So my question is, when an item that is supposed to be on hold and waiting for pickup at one branch gets checked in at a different branch, can Koha display some kind of a message? I really think that it ought to.
Comment 1 Nick Clemens 2015-02-08 02:24:30 UTC

*** This bug has been marked as a duplicate of bug 13153 ***