Bug 12032 - TinyMCE rewrites urls in a very annoying and unexpected way
Summary: TinyMCE rewrites urls in a very annoying and unexpected way
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Liz Rea
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 11883 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-03 03:24 UTC by Liz Rea
Modified: 2014-12-07 20:07 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12032 - TinyMCE rewrites urls in a very annoying and unexpected way (1.54 KB, patch)
2014-04-03 03:28 UTC, Liz Rea
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 12032 - TinyMCE rewrites urls in a very annoying and unexpected way (1.64 KB, patch)
2014-04-03 13:04 UTC, Owen Leonard
Details | Diff | Splinter Review
[PASSED QA] Bug 12032 - TinyMCE rewrites urls in a very annoying and unexpected way (1.69 KB, patch)
2014-04-06 20:31 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2014-04-03 03:24:20 UTC
When making a news item on the Tools -> News page, trying to link to anything inside Koha gets rewritten as a relative path. Sometimes we may not want that, it's probably better to make it so that we have to be explicit about what url we want in there, rather than having TinyMCE try to help.
Comment 1 Liz Rea 2014-04-03 03:28:48 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2014-04-03 13:04:12 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2014-04-06 20:31:18 UTC
Created attachment 26844 [details] [review]
[PASSED QA] Bug 12032 - TinyMCE rewrites urls in a very annoying and unexpected way

To test:

* create a news item with a link in it that is within the same domain

example: my koha was at http://demo.mykoha.co.nz, I created a link in a
news item to http://demo-intra.mykoha.co.nz

* note that when the item is saved, the url changes to ../../../../ (or
something like)

* apply the patch

* edit the link again, and save it

* note that the link is saved correctly

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script.
Comment 4 Galen Charlton 2014-04-07 15:46:14 UTC
Pushed to master.  Thanks, Liz!
Comment 5 Liz Rea 2014-04-23 02:48:17 UTC
*** Bug 11883 has been marked as a duplicate of this bug. ***