Bug 12057 - anonymous suggestions showing to all / own suggestions invisible
Summary: anonymous suggestions showing to all / own suggestions invisible
Status: RESOLVED DUPLICATE of bug 4137
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-09 13:57 UTC by Nicole C. Engard
Modified: 2015-04-28 07:53 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2014-04-09 13:57:13 UTC
If a library allows anonymous suggestions it looks like those are showing to all patrons.  Since the anonymous suggestions do have a borrowernumber I'm not sure how or why this is happening, but I have seen it with my own eyes.
Comment 1 Katrin Fischer 2014-09-11 09:31:39 UTC
There is certainly some weirdness going on here, I have tried a few things now and there is something seriously wrong:

1) If Anonsuggestions is activated, I don't have a 'my purchase suggestions' tab in the patron account.

2) I had created a few suggestions from my account (logged in) and then set the AnonymousPatron to 'not my borrowernumber'. Suddenly my own suggestions are no longer accessible at all, not via the patron account and I am also not seeing them in the purchase suggestions list.
Comment 2 Jonathan Druart 2015-04-28 07:53:26 UTC

*** This bug has been marked as a duplicate of bug 4137 ***