Bug 12058 - OverDrive search results page doesn't show cart, lists, or login links
Summary: OverDrive search results page doesn't show cart, lists, or login links
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Marcel de Rooy
URL: /cgi-bin/koha/opac-overdrive-search.p...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-09 16:09 UTC by Owen Leonard
Modified: 2015-06-04 23:30 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12058 - OverDrive search results page doesn't show cart, lists, or login links (1.41 KB, patch)
2014-04-09 16:21 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 12058 - OverDrive search results page doesn't show cart, lists, or login links (1.47 KB, patch)
2014-04-16 01:10 UTC, Jesse Weaver
Details | Diff | Splinter Review
Bug 12058 - OverDrive search results page doesn't show cart, lists, or login links (1.57 KB, patch)
2014-04-17 07:57 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2014-04-09 16:09:25 UTC
The template for the OverDrive search results page in the OPAC lacks "[% USE Koha %]," so all preference checks (e.g. "[% IF ( Koha.Preference( 'opacbookbag' ) == 1 ) %]") fail.
Comment 1 Owen Leonard 2014-04-09 16:18:28 UTC
More specifically, in the Bootstrap theme.
Comment 2 Owen Leonard 2014-04-09 16:21:21 UTC Comment hidden (obsolete)
Comment 3 Jesse Weaver 2014-04-16 01:10:38 UTC Comment hidden (obsolete)
Comment 4 Marcel de Rooy 2014-04-17 07:57:00 UTC
Created attachment 27228 [details] [review]
Bug 12058 - OverDrive search results page doesn't show cart, lists, or login links

The template for OverDrive search results in the Bootstrap OPAC doesn't
show the cart, lists, or login links because the template's checks of
related system preferences relies on [% USE Koha %], which is not
present. This patch adds it.

To test, enable the bootstrap theme and OverDrive integration
(OverDriveClientKey, etc.). Perform a search in the OPAC and click to
view results from your OverDrive library. Confirm that cart, lists, and
login links appear in the header.

Signed-off-by: Jesse Weaver <pianohacker@gmail.com>
Bug confirmed, and this patch fixes it.

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 5 Galen Charlton 2014-04-17 16:40:33 UTC
Pushed to master.  Thanks, Owen!
Comment 6 Fridolin Somers 2014-08-06 09:53:44 UTC
Pushed to 3.14.x, will be in 3.14.10