Bug 12257 - Suggestions management displays all librarians as "Unknown"
Summary: Suggestions management displays all librarians as "Unknown"
Status: RESOLVED DUPLICATE of bug 10519
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-14 15:26 UTC by Kyle M Hall
Modified: 2014-08-10 16:06 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12257 - Suggestions management displays all librarians as "Unknown" (2.30 KB, patch)
2014-05-14 15:36 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 12257 - Tidy GetCriteriumDesc (2.33 KB, patch)
2014-05-14 15:36 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-05-14 15:26:07 UTC
If you inspect the filter pulldowns for suggested, accepted, or managed by, all the users are listed as "Unknown" instead of his or her name.
Comment 1 Kyle M Hall 2014-05-14 15:36:29 UTC
Created attachment 28262 [details] [review]
Bug 12257 - Suggestions management displays all librarians as "Unknown"

If you inspect the filter pulldowns for suggested, accepted, or managed
by, all the users are listed as "Unknown" instead of his or her name.

Test Plan:
1) Browse to suggestions/suggestion.pl
2) Check the Suggested by, Managed by, and/or Accepted by pulldowns
3) Note the names are all listed as "Unknown"
4) Apply this patch
5) Reload the page
6) Note the names now appear
Comment 2 Kyle M Hall 2014-05-14 15:36:39 UTC
Created attachment 28263 [details] [review]
Bug 12257 - Tidy GetCriteriumDesc
Comment 3 paxed 2014-05-15 04:22:29 UTC
just a heads up: The "Unknown" is untranslatable ...
Comment 4 Paola Rossi 2014-05-30 16:24:45 UTC
I apply the patches against 3.17.00.007.

Now in the dropdown lists for the "Suggested by", "Accepted by", or "Managed by" filters in the left box named "Suggestion information", the known users are listed with their names: OK.

Moreover, the patches have fixed another pre-existent fault too: now the names of the users are seen correctly in the tabs of the answered "Suggestions management", thanks. 

About the comment 3, I changed "AnonSuggestions" pref to "Allow" value, and I kept "AnonymousPatron" pref to "0" value (non-existent patron). On OPAC I create an anonymous suggestion: an "Unknown" user name should appear in the users's dropdown lists of the 3 filters, but it misses.

So I pass the patch to "Failed QA" status.

-----------------------------------------------------------------------
Note 1. Answering to the following selection:
Organized by:
- Library
- Item type

the "Unknown" still appears in the tabs of the answered "Suggestions management" table, instead of the Library's or the item types' right names.
-----
Note 2. If I select "Organized by" Library, koha imposes the current library in the last "Acquisition information" left box.
So, if I select "Organized by" Library, I can't select neither "Any" value nor a library saving the current library.
-----
So I invite you to create another bug about these two next faults, please.
-----------------------------------------------------------------------
Comment 5 ejanla 2014-06-10 03:01:55 UTC
I use a version 3.14 and is still showing UNKNOWN after using the patch placed here, can anyone please help me out I really need this. Thanks
Comment 6 ejanla 2014-06-10 03:02:46 UTC
I use a version 3.14 and is still showing UNKNOWN after using the patch placed here, can anyone please help me out I really need this. Thanks
Comment 7 Katrin Fischer 2014-08-10 16:06:25 UTC
I think this has been fixed by the patches for bug 10519.

*** This bug has been marked as a duplicate of bug 10519 ***