Bug 1232 - Add Invoice/Credit/Fines Payed For Day on Issues (Print Page) (Print Slip)
Summary: Add Invoice/Credit/Fines Payed For Day on Issues (Print Page) (Print Slip)
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement with 6 votes (vote)
Target Milestone: ---
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
: 6287 8591 (view as bug list)
Depends on: 15284
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 04:20 UTC by Chris Cormack
Modified: 2019-04-10 15:27 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-20 23:40:22 UTC


---- Reported by drdrulm@yahoo.com 2006-10-25 04:20:50 ----

It would be very useful for many libraries to add to the end of [PRINT SLIP]/[PRINT PAGE] any transactions such as Invoice/Credits/Fines payed for the current day. Many libraries require receipts for any money being transacted to be given to patrons. Since we are already in the patron record in circulation.pl PRINT SLIP/PRINT PAGE ought to be able to search the current day for any transactions and if any, append them to the end of the PRINT SLIP/PRINT PAGE (or at least the PRINT SLIP page. This would be a great upgrade, perhaps pretty easy to put in.

-Thank you,
D.Ulm



---- Additional Comments From jmf@liblime.com 2007-11-24 19:11:58 ----

Assigning to Ryan and bumping up to HEAD



---- Additional Comments From drdrulm@yahoo.com 2009-07-13 21:05:26 ----

I sent a patch for this today. 

I just added in outstanding balance which was trivial. 

The other improvement I made to the whole thing adds a "quick-slip" to the template so that staff can print 

1) the full page
2) a full slip with overdues included
3) a "quick" slip with only today's checkouts

We needed this because we generally want to give only today's checkouts to patron because it is faster and saves paper (time and cost). 

We also need the full slips for patrons who ask which is about 1 out of 3. We need these because both are required. 

-Darrell Ulm




---- Additional Comments From nengard@gmail.com 2010-02-06 16:09:00 ----

I do not see the additional details on the print slip or print page -- has this patch been pushed?



--- Bug imported by chris@bigballofwax.co.nz 2010-05-20 23:40 UTC  ---

This bug was previously known as _bug_ 1232 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=1232

Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was drdrulm@yahoo.com.
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, gmcharlt@gmail.com.
   Previous assignee was drdrulm@yahoo.com.
CC member bchurch@ptfs.com does not have an account here

Comment 1 Will Stokes 2010-07-29 23:57:15 UTC
Found this message (http://markmail.org/message/nogrzvxextwkzllk) in koha-patches mailing list and found code in HEAD.  This is patch 2 of 2 but unable to locate first patch which I assume would add outstanding balance upon Print Slip.
Comment 2 Chris Cormack 2011-04-30 08:19:44 UTC
*** Bug 6287 has been marked as a duplicate of this bug. ***
Comment 3 Liz Rea 2011-05-20 18:11:58 UTC
possibly 1/2: http://markmail.org/thread/d25nursyxmkqmfzh

Not sure, but would be sweet if true. :)
Comment 4 Nicole C. Engard 2011-05-23 19:40:10 UTC
Neither will work because they are pre-template toolkit.
Comment 5 Chris Cormack 2011-05-24 04:23:12 UTC
Luckily we have a script to fix that. Pre template toolkit doesnt mean it wont work, just means we have to convert them using the script. I sent an email on how to do that pre the release of 3.4.0

If no one beats me to it, ill try to convert these 2
Comment 6 Chris Cormack 2011-07-07 20:51:02 UTC
Patches do not do anything useful.
Comment 7 Katrin Fischer 2015-01-06 18:28:24 UTC
*** Bug 8591 has been marked as a duplicate of this bug. ***
Comment 8 Katrin Fischer 2015-04-07 13:30:54 UTC
Would be nice to see this moving - old and still asked for!
Comment 9 Lisette Scheer 2018-09-12 16:29:35 UTC
This would be great at our library, we have patrons ask for similar slips all the time.
Lisette
Comment 10 Josef Moravec 2018-09-12 20:44:55 UTC
I added dependency on bug 15284, this would be much easier to make with template toolkit syntax in notices. For example: if you add this code notice, you are able to show patron's balance in current Koha:
[% borrower.account.balance %]
Comment 11 Liz Rea 2019-04-10 15:27:08 UTC
You can do this with the TT notices on the slips, with the code snippet provided by Josef.