Bug 12349 - Link patron name on suggestions
Summary: Link patron name on suggestions
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Marcel de Rooy
URL: /cgi-bin/koha/suggestion/suggestion.p...
Whiteboard:
Keywords:
: 18154 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-02 22:03 UTC by Nicole C. Engard
Modified: 2017-11-27 23:52 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18154 - Show card number in detailled suggestion pages (11.61 KB, patch)
2017-05-10 16:45 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 18154 - Show card number in detailled suggestion pages (11.74 KB, patch)
2017-05-10 21:06 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 12349: Show card number in detailled suggestion pages (11.78 KB, patch)
2017-07-07 09:45 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2014-06-02 22:03:32 UTC
It would be great if patron names on suggestions were linked to their patron record.
Comment 1 Owen Leonard 2017-05-10 16:45:25 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2017-05-10 16:47:41 UTC
*** Bug 18154 has been marked as a duplicate of this bug. ***
Comment 3 Marc Véron 2017-05-10 21:06:52 UTC
Created attachment 63370 [details] [review]
Bug 18154 - Show card number in detailled suggestion pages

This patch modifies the main suggestion management page to link patron
names to their details rather than with a "mailto:" link.

This patch also includes the following changes:

- A fix for Bug 18154, Show card number in suggestion details view.
- Changes for brevity to labels in the suggestion details & edit view.
- Addition of the datepicker class to date fields in the suggestion edit
  view.

Signed-off-by: Marc Véron <veron@veron.ch>
Comment 4 Marcel de Rooy 2017-07-07 09:45:25 UTC
Created attachment 64902 [details] [review]
Bug 12349: Show card number in detailled suggestion pages

This patch modifies the main suggestion management page to link patron
names to their details rather than with a "mailto:" link.

This patch also includes the following changes:

- A fix for Bug 18154, Show card number in suggestion details view.
- Changes for brevity to labels in the suggestion details & edit view.
- Addition of the datepicker class to date fields in the suggestion edit
  view.

Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 5 Jonathan Druart 2017-07-10 21:12:15 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 6 Fridolin SOMERS 2017-07-18 12:12:38 UTC
Enhancement not pushed to 17.05.x