Bug 12353 - Reserves last pickup date needs to respect holidays, and everybody need to know the last pickup date for reserves, even notices.
Summary: Reserves last pickup date needs to respect holidays, and everybody need to kn...
Status: RESOLVED DUPLICATE of bug 12063
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Olli-Antti Kivilahti
QA Contact: Testopia
URL:
Keywords:
Depends on: 12917
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-03 04:44 UTC by paxed
Modified: 2019-01-03 08:34 UTC (History)
11 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Initial commitmonster (19.25 KB, patch)
2014-09-12 14:24 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
Bug-12353-Everybody-needs-to-know-the-last-pickup-da.patch (19.23 KB, patch)
2014-09-13 08:50 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
Bug 12353 - Last pickup date in the letter templates (2.64 KB, patch)
2014-09-14 10:36 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
Bug 12353 - Displaying the last pickup date in OPAC and staff client and waitingholds.pl (11.47 KB, patch)
2014-09-14 10:37 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
Bug 12353 - cancel_expired_holds.pl -cronjob respects last pickup date (1.66 KB, patch)
2014-09-14 10:37 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description paxed 2014-06-03 04:44:22 UTC
OPAC does not show the date before which the patron must come and get their reserved book.
Comment 1 Christopher Brannon 2014-06-19 19:52:47 UTC
Would like to see this date on the staff side too.

Christopher
Comment 2 Olli-Antti Kivilahti 2014-09-12 14:24:31 UTC Comment hidden (obsolete)
Comment 3 Olli-Antti Kivilahti 2014-09-12 14:26:03 UTC
Refactored paxed's and seppalaj's work to work with 3.16.3.
Comment 4 Olli-Antti Kivilahti 2014-09-12 14:27:45 UTC
I hope you sign this off Christopher!
Comment 5 Olli-Antti Kivilahti 2014-09-13 08:50:42 UTC Comment hidden (obsolete)
Comment 6 Olli-Antti Kivilahti 2014-09-14 10:36:39 UTC
Created attachment 31584 [details] [review]
Bug 12353 - Last pickup date in the letter templates

Bug 12353 - Last pickup date in the letter templates

    TEST PLAN:

    PREPARE THE LETTER:
    1. Go to Home › Tools › Notices & Slips.
    2. Edit letter template with code HOLD.
    3. Add the <<lastpickupdate>> placeholder to different template types.

    SEND AND RECEIVE THE LETTER:
    1. Create a reservation for a Borrower with pickup branch.
    2. Make sure the borrower receives "Hold waiting for pickup"-notices using the
       message _transport_Type on which you added the <<lastpickupdate>> -placeholder.
    3. Check-in the corresponding Item in the pickup branch and confirm the hold
       for the Borrower
    4. Wait for the message to be delivered and observe your <<lastpickupdate>> being
       replaced with a date.
Comment 7 Olli-Antti Kivilahti 2014-09-14 10:37:16 UTC
Created attachment 31585 [details] [review]
Bug 12353 - Displaying the last pickup date in OPAC and staff client and waitingholds.pl

Bug 12353 - Displaying the last pickup date in OPAC and staff client and waitingholds.pl

    TEST PLAN:

    1. Create a reservation for a Borrower with pickup branch
    2. Check-in the corresponding Item in the pickup branch and confirm the hold
       for the Borrower
    3. Go to circ/circulation.pl for the Borrower and verify that the reservation
       is "Waiting for pickup"
    4. In the
           Home › Circulation › Checkouts -tab (circ/circulation.pl)
       and in the
           Home › Patrons › Patron details -tab
       and in the
           OPAC your summary
       and in the
           circ/waitingreserves.pl
       When looking at reserves, you will find a last pickup date -column added
       which has a value if the reservation is waiting for pickup.
Comment 8 Olli-Antti Kivilahti 2014-09-14 10:37:58 UTC
Created attachment 31586 [details] [review]
Bug 12353 - cancel_expired_holds.pl -cronjob respects last pickup date

Bug 12353 - cancel_expired_holds.pl -cronjob respects last pickup date
Comment 9 Olli-Antti Kivilahti 2014-09-14 10:39:14 UTC
Make sure to test with unicode material!
Comment 10 Tomás Cohen Arazi 2014-09-14 13:57:28 UTC
Please, make sure the functinality changes you introduce get proper unit tests.
Comment 11 Katrin Fischer 2014-09-14 19:13:11 UTC
Hi Olli-Antti,

a few things that have me confused here:

1) Can you please explain how your patches are different to bug 8735? I think we can't have different solutions on master and in 3.16 - this would not make much sense. :)

2) Please only send patches against master, if it's not a problem that only appears in a lower version. Patches don't apply.

3) I think this is somewhere in a grey zone, but more an enh than a bugfix, so should not be for 3.16, but for 3.18. The new placeholder is more like a 'small new feature' than a bugfix.

4) Some of the last pickup dates in the templates use the TT Dates plugin, others don't.
Comment 12 Olli-Antti Kivilahti 2014-09-15 08:27:52 UTC
Thanks for the review Katrin!
Comment 13 Christopher Brannon 2014-09-15 18:42:15 UTC
Olli-Antti,
I did not get notified of your patch.  I will take a look at it when you address the things already in question.

Christopher
Comment 14 Christopher Brannon 2014-09-15 18:44:35 UTC
(In reply to Katrin Fischer from comment #11)
> Hi Olli-Antti,
> 
> a few things that have me confused here:
> 
> 1) Can you please explain how your patches are different to bug 8735?

Katrin,
I don't think this has anything to do with 8735.  8735 addresses the expired date falling on holidays.  Was there a different bug you meant to refer to?

Christopher
Comment 15 Christopher Brannon 2014-09-15 18:46:42 UTC
(In reply to Christopher Brannon from comment #14)
> (In reply to Katrin Fischer from comment #11)
> > Hi Olli-Antti,
> > 
> > a few things that have me confused here:
> > 
> > 1) Can you please explain how your patches are different to bug 8735?
> 
> Katrin,
> I don't think this has anything to do with 8735.  8735 addresses the expired
> date falling on holidays.  Was there a different bug you meant to refer to?
> 
> Christopher

Katrin,

Ignore me.  Didn't see the holidays modifications.  :/  I've been off for 4 days.  Can you tell?

Christopher
Comment 16 Katrin Fischer 2014-09-16 07:09:07 UTC
4 days are forever in terms of Koha :) Hope you had a good time! 
I was not sure how it all fits together, hoping that Olli can explain.
Comment 17 Olli-Antti Kivilahti 2014-09-16 08:31:14 UTC
I didn't know of Bug 8735 when I refactored others work and shared this featureset we have.
I think that bug is very similar, except this bug introduces more stuff.

Do as you please with this, maybe it helps someone else who is looking for the same features to use this code.
Comment 18 Olli-Antti Kivilahti 2014-09-16 08:32:28 UTC
As an important difference this feature removes code duplication regarding holds expiration from 3 different places and centralizes it to actual functions.
Comment 19 Katrin Fischer 2015-04-07 10:33:46 UTC
I was about to file a bug for the holds calculated expiration date not caring about the calendar (calculate ReservesMaxPickUpDelay in opening days vs. calendar days), but will leave a not here instead. This bug seems to have a wider scope tho.
Comment 20 Viccy Kemp 2016-12-21 20:41:17 UTC
Flower Mound Public Library has noticed that reserves DO NOT TAKE INTO ACCOUNT closed holidays. What exactly is the point of marking up a calendar if the software does not know what to do with it. That is nuts. We have been live on Koha for four and a half months now and during both Thanksgiving and now Christmas the closed days are not being accounted for in the holds. Please, someone, figure out how to make this work.
Comment 21 Katrin Fischer 2017-01-04 10:16:20 UTC
Wondering if we should change this to a bug report instead of enh.
Comment 22 Marianne Rolfsen 2017-04-19 10:16:48 UTC
We have the same problem at Oslo public library. Would very much like to fix this!
Comment 23 Katrin Fischer 2017-12-19 13:17:44 UTC
I think the notices are ok, as the pick-up date is in reserves.expirationdate. But we still need to fix the problem with the calendar.
Comment 24 Katrin Fischer 2017-12-19 13:20:24 UTC
Maybe this was fixed by bug 12063?
Comment 25 Katrin Fischer 2019-01-03 08:34:24 UTC

*** This bug has been marked as a duplicate of bug 12063 ***