Bug 12399 - opaccredits printing at top on printable version
Summary: opaccredits printing at top on printable version
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Marc Véron
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-10 12:55 UTC by Nicole C. Engard
Modified: 2015-12-03 22:02 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
footer printing near top (70.02 KB, image/png)
2014-06-10 12:55 UTC, Nicole C. Engard
Details
Bug 12399 - opaccredits printing at top on printable version (9.46 KB, patch)
2015-02-06 17:51 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 12399 - opaccredits printing at top on printable version (9.52 KB, patch)
2015-03-02 08:00 UTC, Brendan Gallagher
Details | Diff | Splinter Review
[PASSED QA] Bug 12399 - opaccredits printing at top on printable version (9.58 KB, patch)
2015-03-05 08:40 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 12399: Small change to remove the whole paging (2.13 KB, patch)
2015-03-05 08:41 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 12399 - opaccredits printing at top on printable version (9.64 KB, patch)
2015-03-05 08:46 UTC, Brendan Gallagher
Details | Diff | Splinter Review
Bug 12399: Small change to remove the whole paging (2.20 KB, patch)
2015-03-05 08:47 UTC, Brendan Gallagher
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2014-06-10 12:55:27 UTC
Created attachment 28758 [details]
footer printing near top

When printing the OPAC in Bootstrap on 3.14 and master the footer prints at the top - see attached.
Comment 1 Marc Véron 2014-06-10 19:51:36 UTC
I can confirm this behaviour. It displays the Koha credits at the wrong place as well.

To reproduce: In Opac with Bootstrap theme, do a search with many results.

It seems that the credits should not display at all in print version, because in opac-tmpl/bootstrap/css/print.css, line 205, a class .koha_url gets "display:none". 
However, there is no class koha_url in the HTML code, but an Id koha_url that should be addressed as #koha_url

Regarding the Id opaccredits (containing the contents from system preference opaccredits), I do not find any traces in print.css
Comment 2 Marc Véron 2015-02-06 16:39:58 UTC
Still valid in current master 3.19.00.008

Additionally, Language selector displays at top of page 2 and overlays other text.
Comment 3 Marc Véron 2015-02-06 17:51:43 UTC Comment hidden (obsolete)
Comment 4 Brendan Gallagher 2015-03-02 08:00:37 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2015-03-05 08:40:50 UTC
Created attachment 36536 [details] [review]
[PASSED QA] Bug 12399 - opaccredits printing at top on printable version

This patch introduces a new class "noprint" in koha-tmpl/opac-tmpl/bootstrap/css/print.css
With this class, unwanted elements can be hidden when printing.

To test:
In OPAC, do a search with many results (> 1 Page)
Print page or do a print preview
See that footer elements are not displayed correctly (as of screenshot in comment #1) and that on top of page 2 the language selector overlays the list
Apply patch
Repeat steps above.
Verify that printed page looks much nicer now by hiding unwanted elements (including e.g. RSS icon, toolbar etc.)

This mechanism can be used on other pages as well.

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 6 Katrin Fischer 2015-03-05 08:41:26 UTC Comment hidden (obsolete)
Comment 7 Brendan Gallagher 2015-03-05 08:46:54 UTC Comment hidden (obsolete)
Comment 8 Brendan Gallagher 2015-03-05 08:47:10 UTC
Created attachment 36539 [details] [review]
Bug 12399: Small change to remove the whole paging

Previous patch only removed the next and previous buttons.
This patch changes it a bit to remove the whole paging from
the print view of the page.

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>
Comment 9 Tomás Cohen Arazi 2015-03-15 12:14:46 UTC
Patches pushed to master.

Thanks Marc!
Comment 10 Chris Cormack 2015-03-21 22:03:48 UTC
String changes held for 3.18.6
Comment 11 Chris Cormack 2015-03-23 07:33:21 UTC
Pushed to 3.18.x will be in 3.18.6