Bug 12507 - News does not always display in staff or OPAC
Summary: News does not always display in staff or OPAC
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-01 03:53 UTC by MetaBiblioteca Colombia
Modified: 2015-12-03 22:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12507 - Don't show News in Staff and opac (800 bytes, patch)
2014-07-31 15:29 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 12507 - News does not always display in staff or OPAC (1.13 KB, patch)
2014-07-31 15:34 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 12507 - News does not always display in staff or OPAC (1.23 KB, patch)
2014-07-31 15:49 UTC, Owen Leonard
Details | Diff | Splinter Review
[PASSED QA] Bug 12507 - News does not always display in staff or OPAC (1.24 KB, patch)
2014-08-02 20:43 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description MetaBiblioteca Colombia 2014-07-01 03:53:31 UTC
In these versions news HOMEPAGE staff and OPAC disappear.
I have the error un the NewsChannels.pm file.
/usr/share/koha/lib/C4/NewsChannels.pm

the error is solved by simply changing the quotes in the line 200:

OLD:
     AND   `timestamp` < CURRENT_DATE()+1
NEW:
     AND   'timestamp' < CURRENT_DATE()+1
Comment 1 Owen Leonard 2014-07-01 12:37:25 UTC
Please paste the error. The news feature works fine for me in the OPAC and staff client in version 3.16.01.
Comment 2 Kyle M Hall 2014-07-31 15:24:18 UTC
I can confirm this bug. There is no error message in the logs!
Comment 3 Kyle M Hall 2014-07-31 15:29:02 UTC Comment hidden (obsolete)
Comment 4 Kyle M Hall 2014-07-31 15:29:56 UTC
I have no idea how to trigger this bug, but the tester can at least prove it does not cause a regression, I think that should be enough!
Comment 5 Kyle M Hall 2014-07-31 15:34:26 UTC Comment hidden (obsolete)
Comment 6 Owen Leonard 2014-07-31 15:49:24 UTC Comment hidden (obsolete)
Comment 7 MetaBiblioteca Colombia 2014-07-31 16:42:03 UTC
Many Thanks for this patch
Comment 8 Katrin Fischer 2014-08-02 20:43:58 UTC
Created attachment 30499 [details] [review]
[PASSED QA] Bug 12507 - News does not always display in staff or OPAC

News will not display on the last day of each month due to the
way the date is calculated in the SQL code for grabbing news.

Test Plan:
1) Create a news item that should display
2) Change your server's date to the last day of the month
3) Note you can no longer see that news item
4) Apply this patch
5) Note you can now see your news item again

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 9 Katrin Fischer 2014-08-02 20:50:02 UTC
Ideally this should have a regression test, but I am not sure how to pretend a specific date for the test to work as it's using SQL to get the current date.
Comment 10 Tomás Cohen Arazi 2014-08-24 16:36:12 UTC
Patch pushed to master.

Thanks Kyle!
Comment 11 Mason James 2015-04-08 08:46:00 UTC
Pushed to 3.16.x, will be in 3.16.10
Comment 12 Mason James 2015-04-08 08:50:10 UTC
(In reply to Mason James from comment #11)
> Pushed to 3.16.x, will be in 3.16.10

Fridolyn, you might want this for 3.14.x?