Bug 12509 - Untranslatable "Restriction added by overdues process"
Summary: Untranslatable "Restriction added by overdues process"
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks: 16893
  Show dependency treegraph
 
Reported: 2014-07-01 10:50 UTC by paxed
Modified: 2017-12-20 16:23 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12509 - Untranslatable : Fix problem with Restriction added by overdues process (3.22 KB, patch)
2016-06-06 14:25 UTC, morgane alonso
Details | Diff | Splinter Review
Follow-up Bug 12509 - Untranslatable : Fix problem with Restriction added by overdues process (8.44 KB, patch)
2016-06-07 13:30 UTC, morgane alonso
Details | Diff | Splinter Review
Bug 12509 - Fix Untranslatable Restriction added by overdues process (11.33 KB, patch)
2016-06-21 07:41 UTC, morgane alonso
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 12509 - Fix Untranslatable Restriction added by overdues process (11.43 KB, patch)
2016-06-22 13:18 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 12509 - Fix Untranslatable Restriction added by overdues process (11.41 KB, patch)
2016-06-24 14:20 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description paxed 2014-07-01 10:50:29 UTC
misc/cronjobs/overdue_notices.pl adds a debarment with an untranslatable comment "Restriction added by overdues process"
Comment 1 Owen Leonard 2016-05-26 16:49:52 UTC
Would it be correct to say that the problem is not necessarily the comment in the database but the output of that comment in the interface?

That is, the goal should be to put a check in the templates which would display a translatable string?
Comment 2 morgane alonso 2016-06-06 14:25:58 UTC Comment hidden (obsolete)
Comment 3 morgane alonso 2016-06-07 13:30:09 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2016-06-20 15:35:57 UTC
This looks good to me and I'm ready to sign off, but I notice the patches don't have correct author information. Credit should not go to "Koha <koha@localhost>"

See https://wiki.koha-community.org/wiki/Version_Control_Using_Git#Getting_Started_with_Git for configuring git with your correct name and email address.

I also suggest that you keep the lines of your commit message under 72 characters long:

https://wiki.koha-community.org/wiki/Commit_messages#Formatting
Comment 5 morgane alonso 2016-06-21 07:41:54 UTC Comment hidden (obsolete)
Comment 6 morgane alonso 2016-06-21 07:45:58 UTC
I squashed my two patches and I changed the credit.
Thanks
Comment 7 Owen Leonard 2016-06-22 13:18:03 UTC Comment hidden (obsolete)
Comment 8 Owen Leonard 2016-06-22 13:19:44 UTC
Your patch still didn't have accurate author information, but I revised it (correctly, I hope) when I signed off.
Comment 9 morgane alonso 2016-06-22 13:39:14 UTC
Thank you so much! The author informations are correct.
I didn't know why the author informations weren't the good ones because I configured my git and I changed it when I squashed my two patches.
Comment 10 Kyle M Hall 2016-06-24 14:20:37 UTC
Created attachment 52804 [details] [review]
Bug 12509 - Fix Untranslatable Restriction added by overdues process

Changes the value of the "comment" column in "borrower_debarments" table
from "Restriction added by overdues process yyyy-mm-dd hh:mm:ss" to
"OVERDUE_PROCESS yyyy-mm-dd hh:mm:ss" in the overdue_notices.pl. Then in
the templates "moremember.tt", "circulation.tt", "memberentrygen.tt",
"opac-reserve.tt" and "opac-user.tt" the value of "comment" is
check, if it's an automatical comment due to overdue process it'll
write "Restriction added by overdues process yyyy-mm-dd hh:mm:ss",
then if there is a customizable comment it will be written without
modification. Like this, the comment "Restriction added by overdues
process" is written in the po files and can be translated later.

To test:
1) create a patron with automatical restriction due to overdue process;
2) apply patch;
3) run misc/cronjobs/overdue_notices.pl;
4) verify if the comment "Restriction added by overdues process" is well
   written and translatable on the following page :
    - opac patron home page (opac-user.tt);
    - opac item reservation page (opac-reserve.tt);
    - pro patron page (moremember.tt);
    - reservation item for a patron (circulation.tt, memberentrygen.tt);
5) try to translate the comment in po files;
6) sign off.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 11 Kyle M Hall 2016-07-08 12:42:19 UTC
Pushed to master for 16.11, thanks Morgane!
Comment 12 Frédéric Demians 2016-08-01 13:20:16 UTC
Pushed in 16.05. Will be in 16.05.02.
Comment 13 Julian Maurice 2016-08-16 14:08:58 UTC
Patch pushed to 3.22.x, will be in 3.22.10