Bug 12510 - In staff client search, per-page search results (cookie) get concatenated needlessly on page reload
Summary: In staff client search, per-page search results (cookie) get concatenated nee...
Status: RESOLVED DUPLICATE of bug 13265
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff interface (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-01 13:41 UTC by Juhani Seppälä
Modified: 2016-04-10 15:05 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Per-page results array concatenation (search cookie) (39.07 KB, image/png)
2014-07-01 13:41 UTC, Juhani Seppälä
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juhani Seppälä 2014-07-01 13:41:45 UTC
Created attachment 29407 [details]
Per-page results array concatenation (search cookie)

When doing a staff client search, clicking on a result and returning to the results using the "return to results" from the top-left navigation, the per-page results array in the search cookie gets concatenated once upon returning to the search results and then every time the page is reloaded. See the attached screenshot. I noticed this behaviour while working on bug 12261.
Comment 1 Mirko Tietgen 2016-04-10 14:58:52 UTC
I saw this in a 3.16. I tried to reproduce in 3.22 but can't. Is this still valid for you? What version of Koha are you using?
Comment 2 Mirko Tietgen 2016-04-10 15:04:48 UTC

*** This bug has been marked as a duplicate of bug 13256 ***
Comment 3 Mirko Tietgen 2016-04-10 15:05:09 UTC

*** This bug has been marked as a duplicate of bug 13265 ***