Bug 12544 - Send scheduled reports as an attachment
Summary: Send scheduled reports as an attachment
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement with 1 vote (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
: 15401 15917 (view as bug list)
Depends on: 15133
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-08 18:42 UTC by Peggy Thrasher
Modified: 2019-06-07 10:27 UTC (History)
10 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12544 - Send scheduled reports as an attachment (4.60 KB, patch)
2015-11-03 19:45 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 12544 - Send scheduled reports as an attachment (4.70 KB, patch)
2015-11-03 19:46 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 12544 - Send scheduled reports as an attachment (5.18 KB, patch)
2015-11-05 16:41 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 12544 - Send scheduled reports as an attachment (4.17 KB, patch)
2015-11-06 13:38 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 12544 - Send scheduled reports as an attachment (4.17 KB, patch)
2015-11-06 13:45 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 12544 - Send scheduled reports as an attachment (4.23 KB, patch)
2015-12-03 18:21 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Peggy Thrasher 2014-07-08 18:42:31 UTC
Currently, a scheduled report is emailed with the report in the body of the email.  If an option was added to allow the report to be sent as a .csv attachment, then these reports could be more easily used in automated ways.
Comment 1 Kyle M Hall 2015-11-03 19:45:14 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2015-11-03 19:46:29 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2015-11-05 16:41:03 UTC Comment hidden (obsolete)
Comment 4 Kyle M Hall 2015-11-06 13:38:56 UTC Comment hidden (obsolete)
Comment 5 Kyle M Hall 2015-11-06 13:45:03 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2015-12-03 18:21:52 UTC
Created attachment 45382 [details] [review]
[PASSED QA] Bug 12544 - Send scheduled reports as an attachment

This patch adds the ability to add the report as an attached file
to the sent email.

Test Plan:
1) Email yourself a test report
2) Apply this patch
3) Repeat step 1, note there is no difference
4) Add the -a parameter, note your also recieve the report as an attachment

Sponsored-by: Briar Cliff University

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Signed-off-by: Julius Fleschner <Julius.fleschner@briarcliff.edu>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Katrin Fischer 2015-12-27 20:43:18 UTC
*** Bug 15401 has been marked as a duplicate of this bug. ***
Comment 8 Brendan Gallagher 2015-12-30 23:22:28 UTC
Pushed to master - thanks
Comment 9 Jonathan Druart 2016-03-01 11:07:52 UTC
*** Bug 15917 has been marked as a duplicate of this bug. ***
Comment 10 Humberto Blanco 2016-03-01 18:27:33 UTC
Dear all, 
this script uses sendmail, but we are using Mail::Sendmail  ani idea to patch this?

Humberto,
Comment 11 Nick Clemens 2019-06-07 10:27:22 UTC
(In reply to Humberto Blanco from comment #10)
> Dear all, 
> this script uses sendmail, but we are using Mail::Sendmail  ani idea to
> patch this?
> 
> Humberto,

I am not sure what the problem is? If still relevant please open a new bug for discussion. Closing this one out